Bug 576121 - Re-basing a single snapshot by 'qemu-img reebase' (reebase spelled correctly is a keyword bellowed by bugzila bots)
Re-basing a single snapshot by 'qemu-img reebase' (reebase spelled correctly ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2 670162
  Show dependency treegraph
 
Reported: 2010-03-23 06:04 EDT by Igor Lvovsky
Modified: 2013-02-28 23:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 670162 (view as bug list)
Environment:
Last Closed: 2011-01-14 11:27:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Igor Lvovsky 2010-03-23 06:04:06 EDT
Description of problem:

We can't rebase a single snapshot.
    base -> sn1

Expected behavior: after qemu-img rebase 'sn1' should contain
(base+sn1) data and shouldn't point to 'base'

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Workaround suggested by kwolf:  base -> sn1
1. Create new empty image 'new-base' similar to 'base'
2. Rebase sn1 on top of 'new-base':
     qemu-img rebase -b new-base -F new-base-fmt sn1
3. Rebase unsafely sn1 on top of "":
     qemu-img rebase -u -b "" sn1
4. Delete 'base' and 'new-base'
Comment 3 RHEL Product and Program Management 2011-01-11 16:15:45 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 17:50:21 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.