Bug 576175 - emacs gtk window has weird default dimensions, fonts appear distorted
emacs gtk window has weird default dimensions, fonts appear distorted
Status: CLOSED DUPLICATE of bug 578048
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Karel Klíč
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-23 09:49 EDT by John Paul Adrian Glaubitz
Modified: 2013-03-03 18:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 12:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the distorted emacs main window (135.88 KB, image/png)
2010-03-23 09:49 EDT, John Paul Adrian Glaubitz
no flags Details
Screenshot of emacs23 on Debian Squeeze (133.82 KB, image/png)
2010-03-23 09:56 EDT, John Paul Adrian Glaubitz
no flags Details

  None (edit)
Description John Paul Adrian Glaubitz 2010-03-23 09:49:52 EDT
Created attachment 402054 [details]
Screenshot of the distorted emacs main window

Hi,

I recently installed Fedora 13 Alpha on my laptop for testing. My primary editor is Emacs which is why I discovered this bug right after installing F13 alpha.

The problem is, that emacs starts with a irregularly shaped main window. Furthermore, the fonts appear distorted as well. Please see the screenshot attached which should tell more than 1000 words.

Thanks,

Adrian
Comment 1 John Paul Adrian Glaubitz 2010-03-23 09:56:11 EDT
Created attachment 402057 [details]
Screenshot of emacs23 on Debian Squeeze
Comment 2 John Paul Adrian Glaubitz 2010-03-23 09:57:54 EDT
I've attached a screenshot of emacs23 on Debian Squeeze for comparison. This reflects the window geometry and fonts of emacs23 on Ubuntu as well.

Adrian
Comment 3 Jonathan Underwood 2010-03-23 10:10:09 EDT
Is this not just a case of different fonts being used on both systems?
Comment 4 Karel Klíč 2010-04-12 10:51:49 EDT
Looks like a font selection issue. 
It seems to be gone with 23.1.9x packages.
Comment 5 Karel Klíč 2010-04-14 08:25:33 EDT
Oh, reproduced today with emacs-23.1.94 from updates-testing.
Comment 6 Karel Klíč 2010-04-18 07:56:29 EDT
Emacs selects "VL Gothic" as its base font on Fedora 13. When changed to "DejaVu Sans", it looks as expected.

1. M-x customize-face RET default RET
2. Change Font Family to "DejaVu Sans"
Comment 7 Karel Klíč 2010-04-19 10:08:22 EDT
I meant "DejaVu Sans Mono".

Maybe this bug can be solved by adding 
Requires: dejavu-sans-mono-fonts
to the spec file (if this font is not installed by default and will be preferred over VL Gothic by Emacs font selection mechanism).

Or we can change face-font-family-alternatives in lisp/faces.el.

I will be able to test it tomorrow.
Comment 8 Karel Klíč 2010-04-20 12:35:45 EDT
This is caused by bug rhbz#578048, and the problem disappears after updating to vlgothic-fonts-20100416-1.

Also similar to rhbz#546490 (fontconfig selection issue).

On Fedora 12:
$ fc-match "monospace:lang=en"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

On Fedora 13 before updating vlgothic-fonts:
$ fc-match "monospace:lang=en"
VL-Gothic-Regular.ttf: "VL Gothic" "regular"

On Fedora 13 after updating vlgothic-fonts:
$ fc-match "monospace:lang=en"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

*** This bug has been marked as a duplicate of bug 578048 ***

Note You need to log in before you can comment on or make changes to this bug.