Bug 57621 - neat's IP alias feature does not work or is hard to understand
Summary: neat's IP alias feature does not work or is hard to understand
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rcn-7.3
TreeView+ depends on / blocked
 
Reported: 2001-12-17 19:02 UTC by Warren Young
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-25 10:10:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Young 2001-12-17 19:02:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Either neat's IP aliasing feature is broken or the feature doesn't work in
an intuitive way.  I have been unable to figure out how to make it work, if
indeed it does work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Assuming you already have an eth0:

1. Go into neat's Devices tab and click the Add button.

2. In the new "Ethernet Device" window, check the "Enable Device Alias
support" checkbox.

3. Leave Hardware Device set to eth0, and set alias to 0 or 1.

4. Say OK, then hit Apply back in the Network Configuration window.
	

Actual Results:  It pops up a warning box saying it can't add that alias.

Expected Results:  It should have added an interface alias for eth0.

Additional info:

For the alias name, I have tried "eth0:0", which fails because it can't
take colons, and I have tried symbolic names, which also fail.  I have also
tried calling the alias eth1, but that doesn't work, either.

Comment 1 Trond Eivind Glomsrxd 2001-12-18 20:31:37 UTC
Can you try the version at http://people.redhat.com/teg/neat/ ?

Comment 2 Warren Young 2001-12-19 13:13:00 UTC
The new version adds the ifcfg-IFNAME file, but the interface doesn't come up on exiting neat, or on rebooting.  Also, the ifup and ifdown commands 
don't work on the IFNAME alone -- you have to pass it the full pathname of the device configuration file, because it's not placed in 
/etc/sysconfig/network-scripts.

Comment 3 Harald Hoyer 2002-02-20 13:13:01 UTC
Should be placed in network-scripts, but with its device name (like "eth0" or "ppp0").. can you confirm this?
Also, if you want the device to be enabled, activate the checkbox, in the device section "Activate device when computer starts".



Comment 4 Harald Hoyer 2002-06-26 13:52:39 UTC
seems to be a profile problem

Comment 5 Trond Eivind Glomsrxd 2002-07-11 16:04:08 UTC
Still a problem in RHL 7.3?

Comment 6 Harald Hoyer 2002-10-23 09:45:04 UTC
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Comment 7 Harald Hoyer 2003-03-25 10:10:03 UTC
see #67498


Note You need to log in before you can comment on or make changes to this bug.