Bug 57622 - Boot-up hangs when initializing PCMCIA
Boot-up hangs when initializing PCMCIA
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-12-17 14:26 EST by Petter Holmstrvm
Modified: 2015-01-04 17:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-25 02:30:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
A kernel patch to run Linux on ACL10 laptops (tested with kernel 2.4.18-5) (1.58 KB, patch)
2002-07-22 06:22 EDT, Nicholas Kudriavtsev
no flags Details | Diff
DMI BIOS dump for Compal ACL10 laptop (3.95 KB, text/plain)
2002-07-24 03:25 EDT, Nicholas Kudriavtsev
no flags Details

  None (edit)
Description Petter Holmstrvm 2001-12-17 14:26:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
I installed RH 7.2 on a MP978 (Chicony) laptop. When I tried to boot from 
CD, the installer hang when initializing PC-cards. I booted from a floppy 
and could continue the installation.
When the installation was finished and I booted up the computer, the boot-
up hung when initializing PCMCIA. This did not happen with RH 7.0.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RedHat 7.2
2. Reboot the computer
3. Wait

Actual Results:  The computer hung.

Expected Results:  The PCIMCIA services should have started and the boot-
up would have finished, allowing me to use the computer.

Additional info:

No error messages were reported.
Comment 1 Nicholas Kudriavtsev 2002-06-26 09:51:15 EDT
The same result with Compal CL10 based notebook and RedHat 7.1
Comment 2 Don Jordan 2002-06-27 19:25:30 EDT
I am using 7.3 with a Compal ACL10 and the same result.
Comment 3 Nicholas Kudriavtsev 2002-07-02 02:45:31 EDT
It is posible to install from cd-rom with 'pci=off' kernel option.
Comment 4 Nicholas Kudriavtsev 2002-07-05 03:22:42 EDT
Some more information.

Compal CL10 (ACL10) has O2 Micro’s OZ6933 CardBus Controller.

Tested OS – RedHat 7.3.

The first boot after installation runs OK. The second boot and others hang on
PCMCIA starting.

After booting with PCMCIA switched off, ‘modprobe pcmcia_core’ is OK. ‘modprobe
yenta_socket’ puts messages
	PCI: No IRQ known for interrupt pin A of device 02:04.0. Please try using
	PCI: No IRQ known for interrupt pin B of device 02:04.1. Please try using
and then hangs.

Pci=biosirq option provides no help.
Comment 5 Nicholas Kudriavtsev 2002-07-22 06:22:33 EDT
Created attachment 66244 [details]
A kernel patch to run Linux on ACL10 laptops (tested with kernel 2.4.18-5)
Comment 6 Nicholas Kudriavtsev 2002-07-22 06:24:05 EDT
OK! At last, I have found workarounds for running Linux on ACL10 laptops.

1. A patch for Redhat’s Linux kernel 2.4.18-5, but I think that patch is
suitable for other releases of 2.4 kernel. Patched file is
arch/i386/kernel/pci-pc.c. The pci-pc.acl10.diff patch in attachment to Bug# 57622.

2. To run nvidia driver you need an updated BIOS. The BIOS that I used from
http://www.v-service.ru/FTP_Files/Notebook/BIOS/CL10/130.zip. Last BIOS from
www.compal.com marked as v0.5A and I did not experiment with it.
Comment 7 Arjan van de Ven 2002-07-22 11:18:19 EDT
Ok unfortionatly I can't add this patch, since it affects ALL notebooks with
this chipset not just your model ;(

Maybe if you send dmidecode output (dmidecode is part of the kernel-utils
package) I can try to make it for your laptop only
Comment 8 Nicholas Kudriavtsev 2002-07-23 03:36:01 EDT
Sure pci-pc.c is not right place for that patch, it is only short cut workaround.

I tried to put the code in dmi_scan.c, but got conclusion that global pci_dev
info structure was not initialized at stage of execution of dmi_scan, so moved
the code to pci-pc.c.

In reference to dmidecode output, I will send it in a few day.
Comment 9 Nicholas Kudriavtsev 2002-07-24 03:25:51 EDT
Created attachment 66744 [details]
DMI BIOS dump for Compal ACL10 laptop
Comment 10 Nicholas Kudriavtsev 2002-07-24 03:32:00 EDT
Original BIOS on laptop was version "V0.05" release "02/09/2001"

Note You need to log in before you can comment on or make changes to this bug.