This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 57628 - grub broken
grub broken
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-17 16:51 EST by Stuart Blake Tener
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-19 17:10:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Blake Tener 2001-12-17 16:51:59 EST
Grub seems to be broken.

I am a former Mandrake 8.1 user, I copied my (working) menu.lst file from 
my Mandrake 8.1 installation (a different hard drive) via a floppy to the 
RH7.2 grub install I did. It never displays the menu!

I think grub has some sort of problem with RH 7.2. Any ideas?

grub does come up when I boot up, and if I type in all the lines manually 
it does bring up RH7.2, but what a lame way too boot.

Stuart
Comment 1 Stuart Blake Tener 2001-12-19 17:10:17 EST
I actually was able to work around this issue by simply tarring up my olde 
grub directory from Mandrake and replacing the RH 7.2 installed grub directory 
with the one from Mandrake, but why didnt it work from scratch with RH 7.2's 
install?
Comment 2 Jeremy Katz 2002-01-02 11:43:01 EST
This is because we use menu.conf as the config file instead of menu.lst.  Either
create a symlink of /boot/grub/grub.conf pointing to your menu.lst file or move
the file.  grub-install already does this if you use it.
Comment 3 Stuart Blake Tener 2002-01-02 13:55:31 EST
I am not sure you are so correct. I did in fact try to link grub.conf to the 
menu.lst file, and the operation of grub still was not displaying the menu. I 
finally ended up just copying my grub directory from my Mandrake installation 
in order to make it work.

However, I do not understand why I needed to do that.

I still have a copy of the grub directory on the hard drive which was 
installed by RH 7.2, and can go back and test it. I am going to call the menu 
file "menu.conf" and not link it to grub, and I will see if that works. But 
like I said, linking grub.conf to menu.lst I tried before I even posted this 
bug report.

Stuart
Beverly Hills, CA

Note You need to log in before you can comment on or make changes to this bug.