Bug 57631 - garbage in syslog messages from wu-ftpd
garbage in syslog messages from wu-ftpd
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: wu-ftpd (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-17 17:17 EST by Jonathan Kamens
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-10 17:24:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to set SPT_PADCHAR to '\0' on linux (511 bytes, patch)
2001-12-17 17:17 EST, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2001-12-17 17:17:27 EST
I saw this in my syslog when I recently FTPd to 127.0.0.1 and logged in
(using my wife's account, which is why it says "andrea" :-):

Dec 17 08:51:47 jik ftpd: localhost.localdomain:
andrea                                                                                                                                                                                                                                                                                                                                                                          
[28076]: FTP LOGIN FROM localhost.localdomain [127.0.0.1], andrea

Yes, that's all on one line in the syslog.  The problem appears to be that
ftpd is using space as SPT_PADCHAR on Linux when it should in fact be using
a null instead.

The attached patch, accompanied by running "autoconf" to regenerate the
configure script, appears to solve the problem, but I'm not sure it's the
*correct* way to solve the problem since there appears to be a hybrid of
two different building mechanisms right now, and I'm not sure the wu-ftpd
development team has yet figured out all the details of how they're going
to set things like SPT_PADCHAR within configure.
Comment 1 Jonathan Kamens 2001-12-17 17:17:51 EST
Created attachment 40868 [details]
patch to set SPT_PADCHAR to '\0' on linux
Comment 2 Jonathan Kamens 2002-02-10 17:24:52 EST
You're not going to ship with this bug unfixed, are you?
Comment 3 Bernhard Rosenkraenzer 2002-02-14 13:53:15 EST
 Fixed in 2.6.2-3

Note You need to log in before you can comment on or make changes to this bug.