Bug 57653 - 2.52x stricter on underquoting
Summary: 2.52x stricter on underquoting
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 59077 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-18 10:29 UTC by vvs
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-19 05:30:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autoconf template file (246 bytes, text/plain)
2001-12-18 10:32 UTC, vvs
no flags Details

Description vvs 2001-12-18 10:29:30 UTC
Description of Problem:

autoconf did produce broken configure script.

Version-Release number of selected component (if applicable):

autoconf-2.52-4

How Reproducible:

always

Steps to Reproduce:
1. save attached configure.in file
2. touch Makefile.am
3. aclocal
4. autoheader
5. automake -a
6. autoconf
7. ./configure

Actual Results:

Syntax error.

Expected Results:

Successful termination.

Additional Information:
	
The above procedure works correctly with autoconf-2.13 from Red Hat 7.2.

Comment 1 vvs 2001-12-18 10:32:13 UTC
Created attachment 40888 [details]
autoconf template file

Comment 2 Jens Petersen 2001-12-19 05:30:34 UTC
Reproduced. This seems to be a bug in the development version which
unfortunately has crept into rawhide.  Perhaps I will revert it to the 2.52 release.

Comment 3 Jens Petersen 2001-12-20 02:21:59 UTC
On second thoughts.  Your example is a case of "underquoting".
The macro calls need to be quoted properly for safe expansion (see "Autoconf
Language" in the autoconf manual).

eg like this:

AC_CHECK_LIB(z, gzsetparams,
             [AC_CHECK_HEADER(zlib.h,,[AC_MSG_ERROR(zlib headers not found)])],
             [AC_MSG_ERROR(zlib library not found)])

The fact that this worked under 2.52 and 2.13 was just pure luck and should not
be relied on.

Comment 4 Jens Petersen 2002-01-31 01:32:28 UTC
*** Bug 59077 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.