Bug 576541 - Garbled characters in Anaconda text UI if lang= is set from kernel command line.
Garbled characters in Anaconda text UI if lang= is set from kernel command line.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-24 08:06 EDT by Milan Kerslager
Modified: 2014-09-30 19:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 20:40:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2010-03-24 08:06:59 EDT
I'm doing network installation. When I use "lang=cs" as kernel parameter, the text screen indicating download of install.img is garbled. When I delete this parameter, there is a text screen to pick up language, but in this case the font initialization is done properly.
Comment 1 Ales Kozumplik 2010-03-25 10:26:39 EDT
Proposing as F13Blocker.
Comment 2 Ales Kozumplik 2010-03-31 09:38:06 EDT
Here's what's going on: 
Newt (the TUI used by Anaconda) and especially s-lang (a library for interactive applications used by newt) handle UTF output according to the setting of the LANG environment variable at the moment of newtInit(). This is still en_EN.UTF-8 if language is set from a dialog, but already cs_CZ.UTF-8 when set from the kernel command line. But to keep the initrd.img small, we only include locale information for english so s-lang doesn't know how to compute character lengths etc if LANG is set to Czech.

Patch coming soon.

Related information:
bug 492999
proposed fixes for bug 492999 (https://www.redhat.com/archives/anaconda-devel-list/2009-May/msg00234.html)
what is locale-archive: http://www.linuxfromscratch.org/pipermail/lfs-support/2004-June/023902.html
Comment 3 James Laska 2010-03-31 10:59:46 EDT
same as bug#578423 ?
Comment 4 Ales Kozumplik 2010-03-31 11:10:21 EDT
No I don't think so James.
Comment 5 Ales Kozumplik 2010-04-01 03:46:08 EDT
Fixed on f13-branch by aa36ed7b195c696d2e5ef7ee374590025c1f99d9.
Fixed on master by 13a8af0887c158553d8b4d2ece02960c3101ff0f.

The bug will be set to modified when its beta-blocking status is determined.
Comment 6 Adam Williamson 2010-05-03 12:12:56 EDT
gack. we missed this because we were skipping MODIFIED blocker bugs during the blocker reviews :(

if this is only a cosmetic bug that only affects one screen during text install while using a rather obscure kernel parameter...I don't think it's a blocker. if we'd reviewed this earlier in the process I'd have wanted to take the fix anyway, but now it seems a bit late. jlaska, oxf13, your opinions?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Jesse Keating 2010-05-03 18:45:53 EDT
this change went in March 31st, and has been in composes since then, so a little late to put the bullet back in the gun.  This just needs to be confirmed as fixed.
Comment 8 Adam Williamson 2010-05-03 20:30:24 EDT
oh, sorry, missed that the fix had gone in. in that case, there's no problem. i should be able to test it in a minute.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Williamson 2010-05-03 20:40:06 EDT
Testing with TC1, whether selecting Czech from the list or specifying lang=cs, the text screen that follows keyboard selection seems to look the same; there's a couple of garbage characters at the right hand end of the very top line, but the rest looks fine. I've seen those same garbage characters in rescue mode too, so I think that's a more general bug. Aside from that, everything seems to behave okay, so I think this is fixed. It seems to proceed to the graphical portion of the installation fine either way.

Note You need to log in before you can comment on or make changes to this bug.