Bug 57657 - grubby option to remove entries by title
Summary: grubby option to remove entries by title
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-18 14:18 UTC by panu.matilainen
Modified: 2007-03-27 03:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 14:20:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adds --remove-title option grubby (1.99 KB, patch)
2001-12-18 14:20 UTC, panu.matilainen
no flags Details | Diff

Description panu.matilainen 2001-12-18 14:18:37 UTC
Here's a small enchancement request to grubby to allow removing entries by
their title. It's useful to me at least :) Patch will follow shortly...

Comment 1 panu.matilainen 2001-12-18 14:20:45 UTC
Created attachment 40907 [details]
adds --remove-title option grubby

Comment 2 Erik Troan 2002-05-21 22:03:53 UTC
Not applied...

This patch missed a couple of things:

   1) Some of the command line error checking wouldn't be correct anymore
   2) You could still set the default image to the one that was just removed!

#2 is the hard one of these to fix.

If you like, rework your patch (follow the checks for oldKernelImage for
hints) and resubmit. I'm not sure how generally useful this feature is though,
so please tell me why you think it's valuable as well or I probably won't
apply it anyway (yes, I could be convinced it is w/o too much effort).

Comment 3 Panu Matilainen 2002-05-22 06:11:00 UTC
Thanks for the feedback, I'll try to get those fixed one of these days (and
since submitting this I found out the patch has other problems as well like only
looking at the first word of the title). 

The reason for this feature is a cornercase (but important one for us) where we
set up a "mini root" partition inside /boot and encrypt the rest of the disk
using various scripts etc from there -> the entry to boot to the miniroot has
the same kernel but different parameters -> it can't be removed by other than
title or manually parsing through grub.conf. I agree it's not probably very
usefull under "normal" circumstances, people who fiddle with their
boot-parameters tend to do so manually and not through grubby.

Based on that explanation do you think you'd apply the patch if I fix the issues
with it - just so I wont bother you unnecessarily with it again? :)


Note You need to log in before you can comment on or make changes to this bug.