Bug 576652 - Cyrus-imapd does not mark QoS on traffic
Summary: Cyrus-imapd does not mark QoS on traffic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd
Version: 12
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL: http://philipp.fedorapeople.org/cyrus...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-24 17:51 UTC by Philip Prindeville
Modified: 2010-05-12 12:20 UTC (History)
2 users (show)

See Also:
Fixed In Version: cyrus-imapd-2.3.16-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-11 19:43:42 UTC
Type: ---


Attachments (Terms of Use)

Description Philip Prindeville 2010-03-24 17:51:48 UTC
Description of problem:

The Internet carries a variety of services, some requiring timely delivery of
traffic, and others not.  The packages providing the majority of server traffic
(http, smtp, imap, ftp, etc) should mark their traffic appropriately so that
other time-sensitive protocols may be differentiated.

RFC-4594 ("Guidelines for DiffServ Service Classes") Section 4.8 designates
Email as a "High-Throughput Data Service Class", requiring markings AF11, AF12,
or AF13.

Currently, Cyrus provides no mechanism to mark traffic.

Version-Release number of selected component (if applicable):

8.14.4

How reproducible:

Source inspection or using tcpdump on an IMAP session.

Steps to Reproduce:
1.
2.
3.

Actual results:

Packets are send with ip_tos as 0x00

Expected results:

Should be 0x28, 0x30, or 0x38.

Additional info:

This fix as been submitted upstream for consideration, and the response was, "The patch that you already submitted looks fine already." (from Ken on 01/11/2010) but it might be a while before it actually appears in a published release.  A quick look at Cyrus's CVS tree shows it hasn't gone in yet.

This functionality isn't enabled until the following change is made to  /etc/imapd.conf:

+qosmarking: af12

Comment 1 Philip Prindeville 2010-03-24 18:20:09 UTC
Errr...  wrong version.  Should be 2.3.16

Comment 2 Michal Hlavinka 2010-04-13 15:24:31 UTC
Hi Philip,

I appreciate your work, I really do, but I'm not going to add any feature patch to cyrus-imapd. We have too much patches now and they are causing a lot of troubles. So this patch has to go upstream first. As you've cited from that mail, it seems upstream will add your patch, but it can take some more time. I'd recommend to add this patch to their bugzilla so they don't forget about it. After you add it to bugzilla (if you did not do it already) send me a link and I'll add my comments there so they can see more interest and they will add the patch in the repository sooner (hopefully).

Comment 3 Philip Prindeville 2010-04-13 17:46:09 UTC
The bug is linked above (see also):

https://bugzilla.andrew.cmu.edu/show_bug.cgi?id=3184

Comment 4 Philip Prindeville 2010-04-13 19:06:59 UTC
I have images for f13 and f12 if anyone wants to try these and post their results.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2113556
http://koji.fedoraproject.org/koji/taskinfo?taskID=2113606

Note that the line:

# qosmarking af13

will need to be uncommented in /etc/imapd.conf

Comment 5 Michal Hlavinka 2010-04-15 15:00:19 UTC
thanks, just note: you should put your builds somewhere, because koji deletes scratch builds quite soon

Comment 6 Philip Prindeville 2010-04-15 18:11:01 UTC
Moving rpm's to http://philipp.fedorapeople.org/

Comment 7 Michal Hlavinka 2010-04-20 12:42:58 UTC
upstream included that patch in the cvs, so I've added it in Fedora 12+ packages

Comment 8 Michal Hlavinka 2010-04-20 12:56:15 UTC
Philip,

please do not remove your rpm builds from fedorapeople for a while, because I've used one of them for bug report #583982

thanks

Comment 9 Fedora Update System 2010-04-20 13:43:38 UTC
cyrus-imapd-2.3.16-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/cyrus-imapd-2.3.16-3.fc12

Comment 10 Fedora Update System 2010-04-20 13:43:43 UTC
cyrus-imapd-2.3.16-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/cyrus-imapd-2.3.16-3.fc13

Comment 11 Philip Prindeville 2010-04-20 16:40:51 UTC
(In reply to comment #8)
> Philip,
> 
> please do not remove your rpm builds from fedorapeople for a while, because
> I've used one of them for bug report #583982
> 
> thanks    

Understood.

Comment 12 Fedora Update System 2010-04-21 02:19:30 UTC
cyrus-imapd-2.3.16-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyrus-imapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/cyrus-imapd-2.3.16-3.fc12

Comment 13 Fedora Update System 2010-04-21 02:21:30 UTC
cyrus-imapd-2.3.16-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyrus-imapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/cyrus-imapd-2.3.16-3.fc13

Comment 14 Fedora Update System 2010-05-11 19:43:37 UTC
cyrus-imapd-2.3.16-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Philip Prindeville 2010-05-11 23:21:57 UTC
Note: there is a missing ':' in the comment on the "qosmarking" line.

I refreshed the .rpm's I have on:

http://philipp.fedorapeople.org/

after noticing this, but wasn't sure it was worth updating the push for it...

Comment 16 Michal Hlavinka 2010-05-12 09:08:57 UTC
fixed in the cvs

Comment 17 Fedora Update System 2010-05-12 12:20:45 UTC
cyrus-imapd-2.3.16-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.