Bug 576681 - Unable to install requested partition scheme - sda must have a MSDOS disk label
Unable to install requested partition scheme - sda must have a MSDOS disk label
Status: CLOSED DUPLICATE of bug 572488
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-24 16:10 EDT by James Laska
Modified: 2013-09-02 02:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-29 04:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (41.66 KB, text/plain)
2010-03-24 16:10 EDT, James Laska
no flags Details
storage.log (242.81 KB, text/plain)
2010-03-24 16:14 EDT, James Laska
no flags Details
program.log (41.91 KB, text/plain)
2010-03-24 16:20 EDT, James Laska
no flags Details
syslog (76.65 KB, text/plain)
2010-03-24 16:21 EDT, James Laska
no flags Details
storage.state (20.00 KB, text/plain)
2010-03-24 16:23 EDT, James Laska
no flags Details
Screenshot.png (102.96 KB, image/png)
2010-03-24 16:50 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-03-24 16:10:17 EDT
Created attachment 402402 [details]
anaconda.log

Description of problem:

Attempting to install F-13-Beta-TC1-x86_64 to a MacbookPro 5,5 with into an existing partition scheme fails.  I believe the partition scheme is valid, but anaconda tells me "sda must be a MSDOS disk label" when attempting to install.

Version-Release number of selected component (if applicable):
 * anaconda version 13.36
 * updates=http://dlehman.fedorapeople.org/updates-576529.img 

How reproducible:
 * everytime

Steps to Reproduce:
 1. Attempt install using the following configuration:

Device Desc            Format?   MountPoint
===============================================
sda1   EFI               NO
sda2   HFS+              NO
sda3   /boot (for F12)   NO
sda4   /boot             YES     /boot
sda5   LVM PV            NO

LVM Setup
 LogVol    VolGroup     New?  Size   Format?   MountPoint
==========================================================
  f12_root vg_flatline   NO   39.06G  NO   
  home     vg_flatline   NO   39.06G  NO       /home
  swap     vg_flatline   NO   2.00G   YES      swap
  f13_root vg_flatline  YES   40G     YES      /

Actual results:

 * Dialog indicating "sda must have a MSDOS disk label"

Expected results:

 * I think this is a valid partition scheme, so it should be okay?

Additional info:

 # parted /dev/sda -s p
Model: ATA FUJITSU MJA2320B (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system  Name                  Flags
 1      20.5kB  210MB  210MB   fat32        EFI system partition  boot
 2      210MB   128GB  128GB   hfs+         Customer
 3      128GB   129GB  524MB   ext4                               boot
 4      129GB   129GB  524MB   ext4
 5      129GB   320GB  191GB                                      lvm
 6      320GB   320GB  21.0MB  ext4
Comment 1 James Laska 2010-03-24 16:14:47 EDT
Created attachment 402404 [details]
storage.log
Comment 2 James Laska 2010-03-24 16:20:10 EDT
Created attachment 402405 [details]
program.log
Comment 3 James Laska 2010-03-24 16:21:38 EDT
Created attachment 402406 [details]
syslog
Comment 4 James Laska 2010-03-24 16:23:36 EDT
Created attachment 402407 [details]
storage.state
Comment 5 James Laska 2010-03-24 16:50:32 EDT
Created attachment 402412 [details]
Screenshot.png
Comment 6 Hans de Goede 2010-03-29 04:28:10 EDT

*** This bug has been marked as a duplicate of bug 572488 ***

Note You need to log in before you can comment on or make changes to this bug.