Red Hat Bugzilla – Bug 57671
gnorpm requires outdated rpm packages
Last modified: 2007-04-18 12:38:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
Description of problem:
rpm complains that gnorpm requires librpm-4.0.3, etc. The current rawhide
rpm package is rpm-4.0.4-0.2.
Perhaps gnorpm should require librpm >4.0.3?
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. I have gnorpm-0.96-1 and rpm-4.0.2-7x installed, and want to upgrade
gnorpm. That requires an upgrade to rpm as well.
2. I downloaded both from the rawhide distro, and tried to install them.
Actual Results: rpm returns:
librpm-4.0.3.so is needed by gnorpm-0.96-11
librpmdb-4.0.3.so is needed by gnorpm-0.96-11
librpmio-4.0.3.so is needed by gnorpm-0.96-11
Expected Results: I expected that the files in the rawhide distro
directory would install/depend upon each other. (I do understand that I am
dealing with Rawhide.)
Thanks a bunch for all the great work.
gnorpm just needs to be rebuilt in rawhide.
0.96-14 should be OK.