Bug 57671 - gnorpm requires outdated rpm packages
gnorpm requires outdated rpm packages
Product: Red Hat Raw Hide
Classification: Retired
Component: gnorpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-12-18 12:20 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-02-26 16:07:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-18 12:20:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
rpm complains that gnorpm requires librpm-4.0.3, etc.  The current rawhide
rpm package is rpm-4.0.4-0.2.  
Perhaps gnorpm should require librpm >4.0.3? 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. I have gnorpm-0.96-1 and rpm-4.0.2-7x installed, and want to upgrade
gnorpm.  That requires an upgrade to rpm as well.
2. I downloaded both from the rawhide distro, and tried to install them.

Actual Results:  rpm returns:
  librpm-4.0.3.so   is needed by gnorpm-0.96-11
  librpmdb-4.0.3.so   is needed by gnorpm-0.96-11
  librpmio-4.0.3.so   is needed by gnorpm-0.96-11

Expected Results:  I expected that the files in the rawhide distro
directory would install/depend upon each other.  (I do understand that I am
dealing with Rawhide.)

Additional info:

Thanks a bunch for all the great work.
Comment 1 Havoc Pennington 2002-01-13 11:47:37 EST
gnorpm just needs to be rebuilt in rawhide.
Comment 2 Havoc Pennington 2002-03-06 11:34:17 EST
0.96-14 should be OK.

Note You need to log in before you can comment on or make changes to this bug.