Bug 57690 - Apache child processes sometimes forget TZ
Apache child processes sometimes forget TZ
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-18 20:56 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-18 20:56:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.16 i686)

Description of problem:
From time to time, one or more Apache child processes 'forget' the local
timezone and use GMT, causing related logging and CGI problems;
an extract from /var/log/httpd/access_log, showing correct asnd incorrect
entries:
 10.5.16.61 - - [17/Dec/2001:09:48:28 +1030] "GET
/faxbhtml/images/group.gif HTTP/1.0" 200 1293
10.5.16.61 - - [16/Dec/2001:23:18:28 +0000] "GET
/faxb/queue.cgi?list=all&all=1 HTTP/1.0" 200 45000
10.5.16.61 - - [17/Dec/2001:09:48:28 +1030] "GET
/faxbhtml/images/failed.gif HTTP/1.0" 200 1052
10.5.16.61 - - [16/Dec/2001:23:18:37 +0000] "GET
/faxb/queue.cgi?list=pending&all=1 HTTP/1.0" 200 5515
10.5.16.61 - - [17/Dec/2001:09:48:40 +1030] "POST /faxb/menu.cgi HTTP/1.0"
200 3573
10.5.16.61 - - [16/Dec/2001:23:18:40 +0000] "GET
/faxbhtml/images/submenu_userlist.png HTTP/1.0" 200 215
10.5.16.61 - - [17/Dec/2001:09:48:40 +1030] "GET /faxb/usermaint.cgi
HTTP/1.0" 200 6025
10.5.16.61 - - [17/Dec/2001:09:48:40 +1030] "GET
/faxbhtml/images/menu_custman_open.png HTTP/1.0" 200 366
10.5.16.61 - - [16/Dec/2001:23:18:40 +0000] "GET
/faxbhtml/images/button_adduser.png HTTP/1.0" 200 244
10.5.16.61 - - [17/Dec/2001:09:48:40 +1030] "GET
/faxbhtml/images/button_deluser

Our tests indicate that it is a problem with the child process - all
requests to affected children get the wrong localtime, reloading 
may fix the problem (depending on whether new children show the bug).



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Restart Apache.
2. Send enough requests to exercise all children;
3. Check TZ on timestamps in access log; goto 1 if necessary
	

Actual Results:  Sometimes, children report the wrong local time; the UTC
is correct, but they apply a timezone offset of 0 in place of whatever is
configured.

Expected Results:  They should show the correect local time, and agree
withb the parent process.

Additional info:

Also running mod_perl-1.21-10, but the problem occurs sporadically for both
mod_perl and regular requests; other servers running the same Apache but
different mod_perl versions show the same behaviour.
Comment 1 Joe Orton 2004-09-21 06:52:08 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.