Bug 57695 - Insufficient cyrillic support: cp1251 screws it all
Summary: Insufficient cyrillic support: cp1251 screws it all
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL: www.rian.ru
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-19 06:25 UTC by Alexei Podtelezhnikov
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 04:59:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
font sources (275.85 KB, application/octet-stream)
2001-12-20 00:44 UTC, Alexei Podtelezhnikov
no flags Details
font cp1251 (759.67 KB, application/octet-stream)
2001-12-20 00:45 UTC, Alexei Podtelezhnikov
no flags Details
font cp1251 (805.28 KB, application/octet-stream)
2001-12-20 00:46 UTC, Alexei Podtelezhnikov
no flags Details

Description Alexei Podtelezhnikov 2001-12-19 06:25:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
When I try to see a cp1251-encoded page web page with Konqueror I looks 
really crappy (www.izvestia.ru - a major russian newspaper). The reason? 
Konqy has very small choice of cp1251 fonts. Particularly, two very crappy 
ones. Konqi doesn't do double re-coding like Mozilla and suffers. The 
problem is easily fixable with an update to XFree86-cyrillic-fonts. It 
already has cronyx fonts in koi8 encoding. Why not add microsoft-cp1251? 
They are available too from Debian: 
http://ftp.debian.org/debian/pool/main/x/xfonts-cronyx/ That's they must 
be legal if Debian has got them.
Anyway, it's a newer version 2.3.7 than 2.3.1 that Red Hat carries now.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try Konqi on www.izvestia.ru
2.
3.
	

Additional info:

Again, please update XFree86-cyrillic-fonts rather than reassigning to 
bero. The present support of cp1251 had better be removed or updated. ... 
and thanks for koi8 support. It's great, just look at 
www.nns.ru/chronicle . That's how it's supposed to look like, and it may, 
once cp1251 components are updated.

Comment 1 Alexei Podtelezhnikov 2001-12-20 00:40:43 UTC
As requested, here is the fresh URL to newest fonts:

http://www.geocities.com/CapeCanaveral/Lab/5735/1/koi8-extended.html#3

Don't be confused this is even newer version 2.3.8 of cyrillic fonts.
You'll find cp1251, koi8, and sources there.

Comment 2 Alexei Podtelezhnikov 2001-12-20 00:44:30 UTC
Created attachment 41069 [details]
font sources

Comment 3 Alexei Podtelezhnikov 2001-12-20 00:45:26 UTC
Created attachment 41070 [details]
font cp1251

Comment 4 Alexei Podtelezhnikov 2001-12-20 00:46:03 UTC
Created attachment 41071 [details]
font cp1251

Comment 5 Alexei Podtelezhnikov 2001-12-20 00:50:28 UTC
Last attachement was in koi8r, sorry. Also...
Mike, maybe it's worth pushing this fonts to XFree86.org? Since they are
descendant of what XFree86 using now (read Changelog.en).
Maybe, it't time to get rid of XFree86-KOI8R-1.0 ? It's so confusing to have
cyrillic fonts in two packages.

Comment 6 Alexei Podtelezhnikov 2001-12-20 06:51:46 UTC
Well... I have to take everything I said and sent back :(
The problem was found to be in ttfonts-ja-1.0-6. Errata-updated -7 fixes all 
this. 

What was happening is that hochi-gothic font and co. contained a lot more than 
just japanese glyphs. They interfered with normal processing of cyrillic fonts 
substituting themselves. In fact, they contained very ugly set of cyrillic 
glyphs, with some characters just plain missing. I hope it will never happen 
again. Basically I rpm -e --nodeps this package. 

Mike, would you reassign this bug to tagoh@redhat.com for closure.

Comment 7 Alexei Podtelezhnikov 2001-12-24 20:14:41 UTC
As a matter of fact. ttfonts-ja-1.1-1 still needs to be fixed.
Please remove all but japanese encodings from it. Non-japanese parts, like 
microsoft-cp1251 for cyrillic, are of extremely bad quality with missing 
characters all over the place.

Comment 8 Mike A. Harris 2002-01-25 00:53:51 UTC
We are moving to new packaging in which the XFree86 packages themselves
contain _only_ the fonts shipped with XFree86.  All other fonts
shipped in the distribution will be in separate packages from now on,
as it eases maintenance, and allows us to update a font package easily
without having to recompile XFree86 needlessly.

Comment 9 Alexei Podtelezhnikov 2002-05-18 21:42:10 UTC
 Closing, since 7.3 seems to behave.


Note You need to log in before you can comment on or make changes to this bug.