Bug 577004 - "The folder contents could not be displayed" error on clean F13 Beta TC1 install
"The folder contents could not be displayed" error on clean F13 Beta TC1 install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: deja-dup (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-25 16:22 EDT by Adam Williamson
Modified: 2010-05-10 08:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-08 16:32:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2010-03-25 16:22:38 EDT
After a clean install of F13 Beta TC1 from the DVD image into a KVM virtual machine, I launch Deja Dup from the menus, and do 'Edit / Preferences'. An error dialog is displayed. In bold: "The folder contents could not be displayed". In regular text: "Operation not supported". Not sure of the practical implications of this bug, but it's very visible.
Comment 1 Adam Williamson 2010-03-25 16:23:26 EDT
This is a final release blocker as it breaks the final release criterion "All applications listed under the Applications menu must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items" - https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria
Comment 2 Rahul Sundaram 2010-03-25 16:42:42 EDT
What is the version number of deja-dup?  I get the error message in deja-dup-13.92-1.fc13.i686 but no crash.
Comment 3 Adam Williamson 2010-03-25 17:13:14 EDT
Yeah, it doesn't crash. I'm being strict about "basic functionality test"; it really shouldn't do this on the first dialog most people will open :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Rahul Sundaram 2010-03-25 17:27:35 EDT
It doesn't break any functionality and while I got that dialog box the first time I ran it, I don't see it on subsequent words. In other words, I don't consider this as a blocker.  Upstream is auto cc'ed on all bug reports so we can get this fixed.
Comment 5 Michael Terry 2010-03-25 21:27:28 EDT
I'm upstream.  This does sound bad.  Can I see /tmp/deja-dup.gconf after running [1] on a fresh install?

It sounds like the default backup location is an unexpected value.  It should default to Amazon S3.

[1] gconftool-2 --dump /apps/deja-dup > /tmp/deja-dup.gconf
Comment 6 Michael Terry 2010-03-26 06:16:04 EDT
Hrm.  I just tested the preferences dialog without installing the schema first, and it gave me that exact error.

I think this is a packaging error.  The gconf schema does not seem to be installed correctly?

/apps/deja-dup/backend should be set to 's3' by default.
Comment 7 Rahul Sundaram 2010-03-26 06:36:39 EDT
I think I understand why.  I will push an update shortly.
Comment 8 Rahul Sundaram 2010-03-31 20:52:15 EDT
Our current guidelines were changed to use macros to do this and I was trying to figure it all out and forgot this step although the review had pointed it out. My mistake. 

Updated to 14.0 and fixed Gconf schema installation.  

http://koji.fedoraproject.org/koji/taskinfo?taskID=2088362

Unfortunately, it won't make into the beta but I will push this as an update immediately. Adam, please test and confirm the fix.  Thanks.
Comment 9 Fedora Update System 2010-03-31 20:53:53 EDT
deja-dup-14.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/deja-dup-14.0-1.fc13
Comment 10 Fedora Update System 2010-04-01 15:32:34 EDT
deja-dup-14.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update deja-dup'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/deja-dup-14.0-1.fc13
Comment 11 Adam Williamson 2010-04-16 12:12:30 EDT
Hum. I just tried on my main system, which didn't have deja-dup installed. Did 'yum install deja-dup', got deja-dup-14.0.2-1.fc13.x86_64 , ran the app, opened the preferences, same error dialog.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Rahul Sundaram 2010-04-22 15:40:15 EDT
Have tried this on multiple systems and can't reproduce this anywhere.
Comment 13 Adam Williamson 2010-04-23 12:47:10 EDT
agreed, just tested with 14.0.3-1 on a system which had never run deja-dup before and couldn't reproduce. Thanks. Closing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2010-05-07 10:24:39 EDT
Unfortunately, this build has never been pushed to stable. No build since 13.92-1 has been, so that's what's on the F13 RC1 images. Since this is a feature of F13, we really should have the latest package, with this and other bugs fixed. Re-opening and nominating as a blocker for discussion.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Rahul Sundaram 2010-05-08 16:32:47 EDT
There seems to have some goofiness here.  I pushed an update and now find that, it has mysteriously disappeared.  

http://lists.fedoraproject.org/pipermail/test/2010-May/090745.html

Jesse Keating took care of it.  Closing again.
Comment 16 Adam Williamson 2010-05-08 18:42:25 EDT
I checked the Bodhi history; until Jesse forced the latest build to stable yesterday, no update had ever made it to stable.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Rahul Sundaram 2010-05-08 19:22:27 EDT
Like I said, something has gone wrong. I actually pushed two updates via bodhi which are currently missing somehow.   These are recorded at 

https://bugs.launchpad.net/ubuntu/lucid/+source/deja-dup/+bug/563062

The reason the first update was not pushed was because it failed to fix a issue and bodhi history would have shown that. 

Upstream fixed this and the second update was on updates-testing repo for 4 days (I was offline during that time because I was hospitalized due to health issues) and yesterday I pushed it to updates repo but both these have now disappeared.
Comment 18 Adam Williamson 2010-05-09 05:43:57 EDT
Yes, I saw both those updates. The point is that neither ever made it to stable, so they weren't included in the final compose - the compose doesn't take packages from testing. It disappeared yesterday because Jesse forced it into stable so we could take it for RC2.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Rahul Sundaram 2010-05-09 06:12:13 EDT
Updated notices shouldn't just disappear like that. It is alarming.  First update wasn't pushed to stable because it still did not resolve the issue.  Second update didn't get enough feedback and I was offline anyway.
Comment 20 Adam Williamson 2010-05-10 08:35:47 EDT
i think it's kind of inevitable when we have to circumvent the normal process like that; it's only going to happen in this kind of scenario (we need to get it in to do the RC compose in time).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.