Bug 577032 - [abrt] crash in gpodder-2.1-3.fc12: urllib2.py:1105:do_open:URLError: <urlopen error [Errno 111] Connection refused>
Summary: [abrt] crash in gpodder-2.1-3.fc12: urllib2.py:1105:do_open:URLError: <urlope...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3bbca3a5
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-25 21:41 UTC by Ira Malinich
Modified: 2010-05-20 18:46 UTC (History)
2 users (show)

Fixed In Version: python-mygpoclient-1.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 18:46:59 UTC


Attachments (Terms of Use)
File: backtrace (1.51 KB, text/plain)
2010-03-25 21:41 UTC, Ira Malinich
no flags Details

Description Ira Malinich 2010-03-25 21:41:15 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/gpodder
comment: I already have a my.gpodder.org account set up and the username and password can be seen in the advanced preferences.
component: gpodder
executable: /usr/bin/gpodder
kernel: 2.6.32.9-70.fc12.i686
package: gpodder-2.1-3.fc12
reason: urllib2.py:1105:do_open:URLError: <urlopen error [Errno 111] Connection refused>
release: Fedora release 12 (Constantine)

backtrace
-----
urllib2.py:1105:do_open:URLError: <urlopen error [Errno 111] Connection refused>

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 2703, in on_download_from_mygpo
    opml_data = client.download_subscriptions()
  File "/usr/lib/python2.6/site-packages/gpodder/my.py", line 100, in download_subscriptions
    opml_data = util.urlopen(url).read()
  File "/usr/lib/python2.6/site-packages/gpodder/util.py", line 840, in urlopen
    return urllib2.urlopen(request)
  File "/usr/lib/python2.6/urllib2.py", line 124, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.6/urllib2.py", line 383, in open
    response = self._open(req, data)
  File "/usr/lib/python2.6/urllib2.py", line 401, in _open
    '_open', req)
  File "/usr/lib/python2.6/urllib2.py", line 361, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.6/urllib2.py", line 1130, in http_open
    return self.do_open(httplib.HTTPConnection, req)
  File "/usr/lib/python2.6/urllib2.py", line 1105, in do_open
    raise URLError(err)
URLError: <urlopen error [Errno 111] Connection refused>

Local variables in innermost frame:
err: error(111, 'Connection refused')
h: <httplib.HTTPConnection instance at 0xb5b829cc>
self: <urllib2.HTTPHandler instance at 0x944fa0c>
req: <urllib2.Request instance at 0x944ffcc>
headers: {'Host': 'my.gpodder.org', 'Connection': 'close', 'User-Agent': 'gPodder/2.1 (+http://gpodder.org/)'}
host: 'my.gpodder.org'
http_class: <class httplib.HTTPConnection at 0x8be95fc>

How to reproduce
-----
1. Launch gPodder
2. Choose "Download from my.gpodder.org" on the Subscriptions menu

Comment 1 Ira Malinich 2010-03-25 21:41:17 UTC
Created attachment 402693 [details]
File: backtrace

Comment 2 Ville-Pekka Vainio 2010-03-25 22:26:03 UTC
This was probably just a symptom of my.gpodder.org server problems, closing.

Comment 3 Ira Malinich 2010-03-25 23:28:28 UTC
Since it's working now that seems likely, but it still triggered abrt.  Couldn't this case be handled better?

Comment 4 Jef Spaleta 2010-03-26 02:22:14 UTC
Yes there's probably a way to catch the URLError as an exception and then spawn a error dialog box or do something else with it.   This should probably re-opened and reported to upstream...especially if we can consistently cause the crash if the url goes dead.

Give me till this weekend and I'll try to patch in a simple URLError exception catch.

-jef

Comment 5 Ville-Pekka Vainio 2010-03-26 06:01:18 UTC
(In reply to comment #4)
> Give me till this weekend and I'll try to patch in a simple URLError exception
> catch.

Ok, I'll reopen this since you're interested in working on it.

Comment 6 Ville-Pekka Vainio 2010-04-05 19:31:25 UTC
I took a quick look at the code and realised that the current versions (> 2.2) of gPodder use python-mygpoclient for interacting with the my.gpodder.org service. If we were to write a patch to handle the URLError, it probably wouldn't be upstreamable as upstream doesn't really care about old versions.

Comment 7 Jef Spaleta 2010-04-06 19:07:41 UTC
(In reply to comment #6)
Are you looking to update F12 to 2.2 at some point soon?  if not I can still make a exception catch patch that will prevent crashes.  Something tells me I can make this crash happen if local network connectivity degrades even if the mygodder site is up and fine. 


-jef

Comment 8 Ville-Pekka Vainio 2010-04-06 19:26:51 UTC
(In reply to comment #7)
> Are you looking to update F12 to 2.2 at some point soon?

I'm not sure. 2.2 or 2.3 require the python-mygpoclient package, which is not in F12 yet, but of course we could ask for the packager to make F12 packages. I've been a bit hesitant on pushing those to F12 especially since all the talk about unstable updates in stable Fedora releases. If it seems like we'd gain 'enough' bug fixes by updating, then I guess we could do it.

Comment 9 Fedora Update System 2010-05-03 10:26:40 UTC
python-mygpoclient-1.4-1.fc12,gpodder-2.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-mygpoclient-1.4-1.fc12,gpodder-2.3-1.fc12

Comment 10 Fedora Update System 2010-05-04 06:03:10 UTC
python-mygpoclient-1.4-1.fc12, gpodder-2.3-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-mygpoclient gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-mygpoclient-1.4-1.fc12,gpodder-2.3-1.fc12

Comment 11 Fedora Update System 2010-05-20 18:46:50 UTC
python-mygpoclient-1.4-1.fc12, gpodder-2.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.