Bug 577052 - (jon24-ewp) Validate support for latest versions of EWP
Validate support for latest versions of EWP
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: John Sanda
Mike Foley
:
Depends On: 562154 589362 591501 591516 601214 jon241-bugs
Blocks: jon24-features
  Show dependency treegraph
 
Reported: 2010-03-25 19:15 EDT by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-27 21:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2010-03-25 19:15:00 EDT
We need to make sure that JON 2.4 works the latest supported versions of EWP:
http://www.redhat.com/docs/en-US/JBoss_Enterprise_Web_Platform/

Check we can monitor/manage EWP as expected across all of its supported platforms using the EAP plugin pack.
Comment 1 John Sanda 2010-04-30 11:19:13 EDT
I have verified that the following works for an EWP server,

* discovery of server and services
* metric collection
* application deployment
* executing resource operations
* creating and configuring a data source
Comment 2 Charles Crouch 2010-04-30 11:27:28 EDT
Can you clarify versions and OSs tested on.
Comment 3 John Sanda 2010-04-30 14:08:48 EDT
I tested with EWP 5.0 and with the source built from the bugfixes branch since that is where I am working. My current HEAD is probably 3 or 4 days behind HEAD in master. I tested on Mac OS X and on a x86_64 Fedora 12 installation.
Comment 4 Charles Crouch 2010-04-30 15:06:06 EDT
Can you validate EWP5.0 is discovered an imported ok on Windows.
Comment 5 John Sanda 2010-05-03 08:35:38 EDT
Verified the following on Windows 2003 Server,

* discovery of server and services
* metric collection
* application deployment
* executing resource operations
* creating and configuring a data source 

Initially I thought that there was a problem with metric collection, but it turned out to a problem with the clocks on my rhq server and windows machine being out of sync.
Comment 6 Corey Welton 2010-09-13 16:36:38 EDT
jsanda - what else needs to be done here?
Comment 7 John Sanda 2010-11-30 16:06:13 EST
Charles, is there additional dev work that needs to be done here, or can we move this to ON_QA?

Note You need to log in before you can comment on or make changes to this bug.