Bug 577056 - (jon24-eap) Add support for EAP5.1
Add support for EAP5.1
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 577065 589362 601880 605272
Blocks: jon24-features
  Show dependency treegraph
 
Reported: 2010-03-25 19:38 EDT by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-27 21:28:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2010-03-25 19:38:06 EDT
We'll need to support EAP5.1 when its released. Prior to release we should test with beta's etc to make sure we have no regressions. In particular we should bundle the HornetQ plugin into JON builds, and test that it plays nicely with the jbas5 plugin (which supports JBoss Messaging), and that both plugins work appropriately given which messaging provider is enabled in EAP.
Comment 1 Charles Crouch 2010-03-25 19:42:15 EDT
HornetQ plugin: https://anonsvn.jboss.org/repos/jbossas/trunk/hornetq-int/
Comment 2 Ian Springer 2010-03-31 18:54:49 EDT
Note, they haven't even created a branch for EAP 5.1 yet. From what Jason G said, they plan to create the branch as soon as EAP 5.0.1 (which is actually a CP) is out the door. 

We should also test against EAP 5.0.1 once it's released (or ideally before) - discovery and management, but also installing the CP via JON on top of an existing EAP 5.0 install.
Comment 3 Corey Welton 2010-09-13 16:37:20 EDT
 ips - what needs to be done here?
Comment 4 Ian Springer 2010-09-13 21:43:03 EDT
EAP 5.1 GA still isn't out, but CR3 was recently released. It would be good to test RHQ against CR3 to flush out any RHQ, or EAP 5.1, bugs.
Comment 5 Ian Springer 2010-09-13 22:01:07 EDT
5.1 CR3 can be downloaded here: http://download.devel.redhat.com/devel/candidates/JBEAP5.0.0/JBEAP-5.1.0-CR3/

5.0.1 GA can be downloaded here:
http://download.devel.redhat.com/released/JBEAP-5.0/5.0.1/zip/

AFAIK, 5.0.1 has not yet been released in the form of a CP for 5.0, due to technical issues with the CSP.

Note You need to log in before you can comment on or make changes to this bug.