Bug 57706 - X fails to start on a docked Dell Latitude C600
X fails to start on a docked Dell Latitude C600
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-12-19 13:01 EST by Daniel Hanks
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-24 19:10:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Hanks 2001-12-19 13:01:32 EST
Description of Problem:
X fails to start on my Dell Latitude C600 laptop when docked. I'm using a Compaq S900 monitor. My guess is that when I attempt to start X, it tries to initialize the LCD instead of the monitor. I can run X just fine when I have Xconfigurator configure for the LCD screen instead.

Version-Release number of selected component (if applicable):

How Reproducible:
Every time

Steps to Reproduce:
1. Run Xconfigurator
2. Which detects the video and monitor (the Compaq S900) correctly, but fails to detect the video ram.
3. Select 8Mb video memory manually
4. Select 1280x1024@24bpp for resolution
5. Test starting X fails

Actual Results:
Xconfigurator attempts to start X, the screen goes blank for a moment, and then the monitor switches as if there is no input signal (The "on" light turns from green to orange).

Expected Results:
X should start up just fine.

Additional Information:
As I mentioned, I can run X just fine on the LCD, but I use this thing docked a lot more than I do undocked.
Comment 1 Patrick C. F. Ernzer 2002-01-07 05:49:22 EST
If you are using the 'ati' driver, you may want to add
        Option "Display" "BIOS"

In Section "Device".

e.g. (on my CPx)

Section "Device"
        Identifier "ATI|Rage Mobility P/M AGP 2x"
        Driver "ati"
        BoardName "Unknown"
        Option "Display" "BIOS"
Comment 2 Daniel Hanks 2002-01-07 12:02:36 EST
Well, I tried your suggestion and:

1) either that worked, 


2) changing the setting in the BIOS to use the laptop's video card instead of the docking station video card (I don't think the docker has one to begin with...) worked 


the combination of those two things fixed the problem. I'm guessing it was your suggestion. Incidentally, Xconfigurator specifies "r128" for the driver. I've switched to "ati" and added the "Display" "BIOS" option as well.

Thanks for your help.
Comment 3 Mike A. Harris 2002-01-24 19:09:39 EST
Just to add some information.  There are 3 ATI video drivers that come
with XFree86 4.x.  "ati", "r128", "radeon"

Each one of those drivers is for the specific chipset family.  The
"radeon" driver *only* works with Radeon hardware, the "r128" driver
*only* works with ATI Rage 128 hardware, and the "ati" driver *only*
works with Mach64 and older hardware.

Quite often when someone has a problem, someone else will suggest trying
one of the other ATI drivers "just in case".  This information is
false however and will not change a thing.  Each of the 3 drivers,
support only that specific chipset family that they were designed for.
The drivers were however made a bit smart, so that if someone specifies
the wrong driver (choosing r128 driver for a Mach64 card), the driver
internally bails out, and starts the correct driver instead - overriding
the user's selection.  So in short, if "ati" driver does not work,
choosing "r128" as the driver, only causes the "r128" driver to start
up, go "hmm, this is not an r128 card", and then it starts up the "ati"
driver instead, and bails.

Likewise for other invalid combinations.  One additional thing however,
is that choosing the wrong driver, does not always work.  Sometimes
the autodetection logic in the wrong driver, will fail and not be able
to load the correct driver.

In the end, the proper thing to do, is use the correct driver at all
times.  If it fails, then it is either a misconfiguration, or a bug
in the driver, or some other issue.  In any case, choosing the wrong
driver "just to see if it works" will not ever yeild better results
by design.
Comment 4 Mike A. Harris 2002-07-26 07:10:35 EDT
Closing as resolved in CURRENTRELEASE (RHL 7.3)

Note You need to log in before you can comment on or make changes to this bug.