Bug 577239 - RFE : Obfuscation of comm/ssl passwords in rhq-server.properties
RFE : Obfuscation of comm/ssl passwords in rhq-server.properties
Status: CLOSED DUPLICATE of bug 1070262
Product: RHQ Project
Classification: Other
Component: Communications Subsystem (Show other bugs)
1.4
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: JON3-40/PRODMGT-411
  Show dependency treegraph
 
Reported: 2010-03-26 10:40 EDT by Jay Shaughnessy
Modified: 2014-05-28 08:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 08:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2010-03-26 10:40:48 EDT
Customer request to add obfuscation for the comm and ssl passwords in rhq-server.properties.

Note, rhq-db password obfuscation is already being implemented. See https://bugzilla.redhat.com/show_bug.cgi?id=535601.
Comment 1 Jay Shaughnessy 2010-03-26 10:43:18 EDT
10:32:34 AM) mazz: for the record, that would require some amount of non-trivial work to get the obfuscated keystore/truststore passwords into the rhq comm layer
(10:33:12 AM) mazz: at the very least, we'd have to have some kind of "salt" inside the comm java code like we have in the license stuff


Also, note the following about Tomcat and AS embedded Tomcat

"BTW: looks like jboss added this obfuscation feature to the embedded tomcat connector config

http://community.jboss.org/wiki/EncryptKeystorePasswordInTomcatConnector

so while tomcat doesn't support it, jboss does (for the tomcat it embeds)"
Comment 2 Jay Shaughnessy 2014-05-27 21:30:43 EDT
Mazz, anything pending here or can we close this?
Comment 3 John Mazzitelli 2014-05-28 08:00:34 EDT

*** This bug has been marked as a duplicate of bug 1070262 ***

Note You need to log in before you can comment on or make changes to this bug.