Bug 57730 - SSL problem in 2.2.2 but not in 2.2
SSL problem in 2.2.2 but not in 2.2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 07:21 EST by Tim Waugh
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 17:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-12-20 07:21:29 EST
Description of Problem:
Konqueror in KDE 2.2.2 is unhappy with the certificate for my bank 
(HSBC), although konqueror in 2.2 is fine with it and so is mozilla.

Version-Release number of selected component (if applicable):
kdebase-2.2.2-1
kdelibs-2.2.2-1

How Reproducible:
100%

Steps to Reproduce:
1. Use konqueror to access my bank account. :-)

The problem only happens after I type in my correct pass phrase, 
unfortunately.

Actual Results:
A message 'The certificate is valid but does not appear to have been 
assigned to this server.  Do you wish to continue loading?' appears.

Expected Results:
It never used to appear.  I'd like to know more information about the 
certificate so that I can complain to either HSBC or the KDE developers, 
whoever is at fault.  But that's all the information I have.

Additional Information:
How can I get more information about this so that we can diagnose it?
Comment 1 Alexei Podtelezhnikov 2002-01-13 15:42:23 EST
Try downgrading to the original qt-2.3.1-5 ... It might fix this.
Comment 2 Tim Waugh 2002-01-14 02:53:53 EST
No change.
Comment 3 Alexei Podtelezhnikov 2002-01-14 20:27:55 EST
Then this might be related:
http://lists.kde.org/?l=kde-devel&m=100654692123729&w=2
The fix is in their cvs. Heh, if you could only ask bero to rebuild 2.2.2 from 
current cvs based on good'ol qt 2.3.1.
Comment 4 Bernhard Rosenkraenzer 2002-01-22 12:07:18 EST
Do you still see this with the versions in 7.2-errata-candidate? 
Works for my bank (but so did the old version).
Comment 5 Tim Waugh 2002-01-22 12:37:29 EST
No change with kdelibs-2.2.2-2.
Comment 6 Bernhard Rosenkraenzer 2002-01-22 15:31:22 EST
Odd, because the patch mentioned above is in.
Can you check whether the bank is doing something odd like using a different
domain name in a frame?
Comment 7 Tim Waugh 2002-01-23 06:28:01 EST
Doesn't seem to be.  Actually now that I look at this again you don't need a login to show the problem.  Go to:

https://www.ebank.hsbc.co.uk/loginindex.html

and click on 'Enter internet bnking' on the left hand side.
Comment 8 Ngo Than 2004-10-07 17:32:17 EDT
i cannot verify this problem without account here. It's great if you
could do it please ;-). Reopen it again if this problem still appears
in fc2 and fc3test3. Thanks

Note You need to log in before you can comment on or make changes to this bug.