Bug 57731 - Dissabling og AUTH doesn't work
Dissabling og AUTH doesn't work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 07:23 EST by Vidar Langseid
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 08:34:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidar Langseid 2001-12-20 07:23:30 EST
Description of Problem:
Hi 
I am trying to dissable AUTH authentication from wu-ftp
$ man ftpd says
"The  -I  option disables the use of RFC931 (AUTH/ident) to attempt to
determine the username on the client."

So I change to the following in /etc/xinetd.d/wu-ftpd (and restarts xinetd)
server_args             = -l -a -I

Version-Release number of selected component (if applicable):
wu-ftpd-2.6.1-16.7x.1 (yepp, the one from the errata )

How Reproducible:
always

Steps to Reproduce:
1. Use ipchains and enable packet logging of AUTH packages (port 113)
2. ftp to ftpserver
3. take a look in /var/log/message on the ftpserver:
Dec 20 12:59:27 localhost kernel: Packet log: output ACCEPT eth0 PROTO=6
myftpserver:35938 myclient:113 L=60 S=0x00 I=52407 F=0x4000 T=64 SYN (#2)




Actual Results:
wu-ftp sends AUTH packages even though I have dissabled it

Expected Results:
I don't excpect any AUTH packages to be sendt

Additional Information:
I was temporary confused since both wu-ftpd and krb5-workstation has a ftpd
man page ("$man ftpd" gave me the one from krb5-workstation):
$ rpm -ql krb5-workstation|grep ftpd
/usr/kerberos/man/man8/ftpd.8.gz
rpm -ql wu-ftpd|grep ftpd|grep man
/usr/share/man/man8/ftpd.8.gz
Comment 1 Michael Ellis 2002-02-22 14:09:08 EST
Bug is also present on Red Hat 7.2 systems. (RPM wu-ftpd-2.6.1-20)
Comment 2 Thomas Woerner 2004-02-19 08:34:36 EST
Please use vsftpd, wu-ftpd is not maintained anymore.

Note You need to log in before you can comment on or make changes to this bug.