Bug 57734 - gnorpm fail when run as root or in su'd shell
gnorpm fail when run as root or in su'd shell
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 09:04 EST by Colin Wu
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 15:50:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Wu 2001-12-20 09:04:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
gnorpm (0.96) works as non-root user, but fails with "XML-CRITICAL **:
Document is empty\nXML-CRITICAL **: Start tag expect, '<' not found" when
run as root or in su'd shell WHEN THE "WEB FIND" BUTTON IS CLICKED.

Version-Release number of selected component (if applicable):
0.96

How reproducible:
Always

Steps to Reproduce:
1.login as root, or su to root
2.execute gnorpm from command line
3.click on "Web find" button
4.look at output in shell 
	

Actual Results:  The Web find window opens but all fields are empty or
place-holders. The program outputs the following to the terminal:

XML-CRITICAL **: Document is empty

XML-CRITICAL **: Start tag expect, '<' not found



Expected Results:  "Web find" window should open and display list of
available rpm's for download and/or install.

Additional info:

This behavior started after I recently upgraded Perl from the distribution
version to v5.6.1 via CPAN module's "install Bundle::CPAN".

The gnorpm version is 0.96, rpm version is 4.0.3.
Comment 1 Havoc Pennington 2002-02-26 15:58:32 EST
Works OK for me; perhaps the new Perl somehow replaced the XML or other relevant
libraries?

In any case, deferring gnorpm bugs since we are working on replacing rather than
repairing it. Suggest using up2date as well.

Note You need to log in before you can comment on or make changes to this bug.