Bug 577387 - fetch-crl getopt syslog bug.
Summary: fetch-crl getopt syslog bug.
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: fetch-crl
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-26 20:22 UTC by Jason Smith
Modified: 2010-04-15 23:48 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-04-09 01:39:31 UTC


Attachments (Terms of Use)
Patch file. (1.15 KB, patch)
2010-03-26 20:22 UTC, Jason Smith
no flags Details | Diff
Patch for new random wait bug. (632 bytes, patch)
2010-04-05 20:54 UTC, Jason Smith
no flags Details | Diff

Description Jason Smith 2010-03-26 20:22:55 UTC
Created attachment 402940 [details]
Patch file.

Description of problem:
Source code contains an option parsing bug.

Version-Release number of selected component (if applicable):
fetch-crl-2.8.2-1.el5.noarch

How reproducible:
Always

Steps to Reproduce:
1./usr/sbin/fetch-crl -f user -v
  
Actual results:
Exits with an error:
fetch-crl: unexpected argument 'user'

Expected results:
Should run and log to syslog with facility user.

Additional info:
Patch for this bug is attached.

Comment 1 Steve Traylen 2010-03-26 21:47:03 UTC
Hi Jason,

Looks trivial given your patch, new packages in next few days.
Steve

Comment 2 Fedora Update System 2010-03-27 10:02:37 UTC
fetch-crl-2.8.2-2.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.2-2.el4

Comment 3 Fedora Update System 2010-03-27 10:03:27 UTC
fetch-crl-2.8.2-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.2-2.el5

Comment 4 Fedora Update System 2010-03-27 10:03:58 UTC
fetch-crl-2.8.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.2-2.fc11

Comment 5 Fedora Update System 2010-03-27 10:04:29 UTC
fetch-crl-2.8.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.2-2.fc12

Comment 6 Fedora Update System 2010-03-27 10:05:00 UTC
fetch-crl-2.8.2-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.2-2.fc13

Comment 7 Fedora Update System 2010-03-28 17:44:44 UTC
fetch-crl-2.8.3-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.el4

Comment 8 Fedora Update System 2010-03-28 17:45:32 UTC
fetch-crl-2.8.3-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.el5

Comment 9 Fedora Update System 2010-03-28 17:46:10 UTC
fetch-crl-2.8.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.fc11

Comment 10 Fedora Update System 2010-03-28 17:46:47 UTC
fetch-crl-2.8.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.fc12

Comment 11 Fedora Update System 2010-03-28 17:47:21 UTC
fetch-crl-2.8.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.fc13

Comment 12 Fedora Update System 2010-03-30 02:15:03 UTC
fetch-crl-2.8.3-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.fc12

Comment 13 Fedora Update System 2010-03-30 02:26:00 UTC
fetch-crl-2.8.3-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.fc11

Comment 14 Fedora Update System 2010-04-01 19:30:07 UTC
fetch-crl-2.8.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.fc13

Comment 15 Fedora Update System 2010-04-01 21:02:16 UTC
fetch-crl-2.8.3-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.el4

Comment 16 Fedora Update System 2010-04-01 21:03:12 UTC
fetch-crl-2.8.3-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.3-1.el5

Comment 17 Jason Smith 2010-04-05 20:54:56 UTC
Created attachment 404568 [details]
Patch for new random wait bug.

Hi Steven,

Since this is still listed as in QA, maybe this is not too late.  We noticed a minor bug introduced in the update to 2.8.3, where it allows passing zero to the -r option.  When the script is called without the -r option, the following error is reported:

/usr/sbin/fetch-crl: line 592: [: too many arguments

Attached is a patch to fix this.

~Jason

Comment 18 Steve Traylen 2010-04-05 21:04:05 UTC
Hi Jason,

 No it's not to late.

 Ahead of you but only by a few hours bug #579488
 is fixed and all will come out the same time.
 
 It resets the counter for this one to two weeks in testing though.

 You should get notifications as it advances through.
 Steve.

Comment 19 Fedora Update System 2010-04-06 19:55:22 UTC
fetch-crl-2.8.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.4-1.fc13

Comment 20 Fedora Update System 2010-04-07 22:16:00 UTC
fetch-crl-2.8.4-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.4-1.el5

Comment 21 Fedora Update System 2010-04-07 22:18:25 UTC
fetch-crl-2.8.4-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fetch-crl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fetch-crl-2.8.4-1.el4

Comment 22 Fedora Update System 2010-04-09 01:39:18 UTC
fetch-crl-2.8.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2010-04-09 01:42:22 UTC
fetch-crl-2.8.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2010-04-09 03:48:33 UTC
fetch-crl-2.8.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2010-04-15 23:48:03 UTC
fetch-crl-2.8.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2010-04-15 23:48:46 UTC
fetch-crl-2.8.4-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.