Bug 57746 - WindowMaker 0.70 doesn't play nicely with GNOME over virtual desktops
WindowMaker 0.70 doesn't play nicely with GNOME over virtual desktops
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: WindowMaker (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 12:27 EST by Bill Crawford
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-13 12:20:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of what I get (41.81 KB, image/jpeg)
2001-12-20 12:45 EST, Phil Copeland
no flags Details
Quick snapshot of the desk guide applet with task list (8.70 KB, image/png)
2001-12-20 13:21 EST, Bill Crawford
no flags Details
Fix wmaker/gnome-deskguide communication. (675 bytes, patch)
2002-01-08 13:09 EST, Bill Crawford
no flags Details | Diff

  None (edit)
Description Bill Crawford 2001-12-20 12:27:35 EST
Description of Problem:
"Desk Guide" applet no longer shows my 8 virtual desktops (or are they
workspaces? :o)
Also, when I first did the upgrade and restarted wmaker to pick up the new
binary, clicking on the desk guide would no longer switch workspaces.

If I click on the little arrow at the side of the desk guide to bring up
the window list, all windows are listed as Desktop number 0.

Seems to be some (mis)communication problem between wmaker and GNOME.
Comment 1 Phil Copeland 2001-12-20 12:45:11 EST
Humm,..
See attachment.
Do you see something different?
If possible can you send me a screenshot? (gimp or xv does the trick)

Cheers

Phil
=--=
Comment 2 Phil Copeland 2001-12-20 12:45:47 EST
Created attachment 41107 [details]
Image of what I get
Comment 3 Bill Crawford 2001-12-20 13:05:11 EST
Ah, no, I meant the GNOME Desk Guide Applet.  If you enable the pop-up tasklist
(it seems to be off by default) then click on the little arrow next to it.  I'm
using GNOME with wmaker as the window manager and a panel at the bottom.  I've
had trouble with the combination before; if it gets any harder to use I'll just
use wmaker on its own.

Oddly enough, if I update the RPMs and restart wmaker, it seems to carry on
working OK, but fails next time I start X up from scratch.

I'll restart in a while and take a snapshot for you.
Comment 4 Bill Crawford 2001-12-20 13:21:01 EST
OK, this (next attachment) is a shot of the deskguide with the task list popped
up.  There was an xterm on workspace 1 and an xterm + gimp on workspace 2 (i.e.
desktops 0 and 1), but all are listed as desktop 0.  Also I have eight
workspaces/desktops, but the desk guide only shows one.

For all I know this could be some timing issue, that doesn't show up with the
older version of wmaker; I've seen some odd failures at home with the older
version (occasionally there's a popup "You're not running a GNOME-compliant
window manager").
Comment 5 Bill Crawford 2001-12-20 13:21:47 EST
Created attachment 41108 [details]
Quick snapshot of the desk guide applet with task list
Comment 6 Bill Crawford 2001-12-20 17:39:46 EST
Exactly the same thing happens on my box here at home, just tried it.  This is a
fully up-to-date Raw Hide, barring the kernel which I've kept at 2.4.16-0.5 ...
Comment 7 Phil Copeland 2002-01-08 10:55:40 EST
Ok, I talked to havoc pennington about this (elite haxor for the gnome group)
<much "oh my gawd, thats sooo wrong" deleted>

Basically this is very old code written a couple of years ago. the gnome pannel
piece looks at hints from the window manager to work out what screen it's on but
apparently this is dependant in the gnome code not on WindowMakers side.

Really this boils down to a 'what the heck is the gnome bit looking for which is
unfortunately havoc's dept not mine. I don't see this being resolved anytime
soon as I'm also handling the php package which has been prioritized. 

I'll keep you appraised of how things go but I think this one went  into the low
priority basket for now
Comment 8 Havoc Pennington 2002-01-08 11:25:57 EST
Just to be clear, the problem could very well be in windowmaker, it's just that 
it will probably need to be debugged by tracing the desk guide to see where the
communication with window maker breaks down.
Comment 9 Bill Crawford 2002-01-08 13:05:45 EST
I found the problem, in fact.  It's fixed by a two-lie addition in the 0.80
patch for WindowMaker.  I've extracted the relevant bit; it needs to be
credited.  Line from the changlog is:

- Added patch to fix some gnome issues (Les Schaffer <schaffer@optonline.net>)

I'll attach the two-liner in a minute.  You could either add this as a patch or
just bump up to 0.80.
Comment 10 Bill Crawford 2002-01-08 13:09:30 EST
Created attachment 42031 [details]
Fix wmaker/gnome-deskguide communication.
Comment 11 Bill Crawford 2002-01-08 13:14:18 EST
So, basically it is a wmaker bug, although it seemed odd that the older version
(0.65) was working fine.  I havn't investigated further as this fixes it for me.

I wouldn't mind seeing a new version in Raw Hide (hint, hint) with either this
fix or the whole 0.80, but I havn't tried 0.80 in full yet (just looked in the
ChangeLog for anything GNOME-related and found this fix).  0.70 with fix works a
treat.
Comment 12 Bill Crawford 2002-01-13 11:42:06 EST
0.80 doesn't play nice (tried it at work, it aborts every time I close a window
on the same display as the GNOME panel, but bizarrely is fine handling windows
on :0.1 which doesn't have a panel.  Looks like the GNOME support is still
rather fragile in wmaker; I'm hoping to find time to look at this (probably
quicker to solve this than to try writing my own window manager, which would be
wasteful and possibly rather arrogant of me).

0.70 is fine with this little patch though.
Comment 13 Havoc Pennington 2002-01-13 12:20:02 EST
Heh, I wrote my own window manager. ;-) If you basically like the window maker
UI though it probably doesn't make sense, windowmaker has clean code.
Comment 14 Bill Crawford 2002-04-02 19:20:01 EST
Seems to work alright in the current version (some other issues, I'll create a
new bug).

Note You need to log in before you can comment on or make changes to this bug.