Bug 577480 - Won't handle xz compressed files; can't open rpm files
Summary: Won't handle xz compressed files; can't open rpm files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xarchiver
Version: 15
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 711983 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-27 11:46 UTC by Steven Usdansky
Modified: 2015-03-19 20:30 UTC (History)
3 users (show)

Fixed In Version: xarchiver-0.5.2-10.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 17:53:40 UTC


Attachments (Terms of Use)
Fixed xz patch (14.20 KB, patch)
2011-06-09 12:07 UTC, Daniel Hokka Zakrisson
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1122171 None None None Never

Internal Links: 1122171

Description Steven Usdansky 2010-03-27 11:46:26 UTC
Description of problem:
The current version of xarchiver cannot open xz-compressed files

Version-Release number of selected component (if applicable):
xarchiver-0.5.2-5.fc12.i686

How reproducible:
100%

Steps to Reproduce:
1. download xarchiver-0.5.2-5.fc12.i686.rpm
2. run the command: xarchiver xarchiver-0.5.2-5.fc12.i686.rpm
  
Actual results:
bzip2: /tmp/xa-Ly2tRE/file.gz_bz is not a bzip2 file.


Expected results:
rpm file opens and I see its contents

Additional info:
Found a patched version at http://support.zenwalk.org/viewtopic.php?f=37&t=25656
that can handle xz files, but it does not recognize rpm files. Upstream doesn't appear to be very active (other than translations)

Here is the error I get when running the zenwalk version on 
xarchiver-0.5.2-5.fc12.i686.rpm:

xz: /tmp/xa-EiVTmu/xarchiver-0.5.2-5.fc12.i686.rpm: Filename has an unknown suffix, skipping

file-roller is not a lightweight option:
================================================================================
 Package                       Arch       Version              Repository  Size
================================================================================
Installing:
 file-roller                   i686       2.29.92-1.fc13       fedora     1.1 M
Installing for dependencies:
 gnome-desktop                 i686       2.29.92-1.fc13       fedora     994 k
 gnome-python2-gnome           i686       2.28.0-2.fc13        fedora      69 k
 goddard-backgrounds-gnome     noarch     12.91.0-2.fc13       fedora     4.2 k
 nautilus                      i686       2.29.92.1-1.fc13     fedora     3.5 M
 nautilus-extensions           i686       2.29.92.1-1.fc13     fedora      51 k

Transaction Summary
================================================================================
Install       6 Package(s)
Upgrade       0 Package(s)

Total download size: 5.7 M
Installed size: 24 M

Comment 1 Christoph Wickert 2010-03-27 12:19:16 UTC
Thanks for you report. Currently I have nether time nor intentions to work on this, upstream already has a request for this, see
http://sourceforge.net/tracker/?func=detail&aid=2870510&group_id=140153&atid=745600

As long as rpms are not supported, I will remove the mime type from the desktop file, so xarchiver is not suggested/associated.

Comment 2 Christoph Wickert 2010-03-27 13:05:16 UTC
Upstream author himself has submitted a request, so I guess he is working on it:
https://sourceforge.net/tracker/?func=detail&aid=2847624&group_id=140153&atid=745600

Comment 3 Raphael Groner 2010-11-27 21:53:20 UTC
Here is a patch from Slackware.

http://slackbuilds.org/slackbuilds/13.1/system/xarchiver/xarchiver-0.5.2-add_xz_support.patch

Comment 4 Christoph Wickert 2010-11-27 22:07:42 UTC
Thanks. I wonder why Slackware has not added it to the upstream bug report.

Comment 5 Raphael Groner 2010-11-27 22:50:26 UTC
Zenwalk (link in comment #0) uses the same patch as slackbuilds.org (comment #3).
But it is about xz support, not lzma as used in rpm.
Sorry for any confusion.

Comment 6 Daniel Hokka Zakrisson 2011-03-27 01:21:03 UTC
See http://daniel.hozac.com/tmp/xarchiver-0.5.2-rpm2cpio.patch for a simple patch that makes it work on RPM-based systems (and others with rpm installed).

Comment 7 Raphael Groner 2011-05-21 14:38:12 UTC
Is it patched in / for Fedora 15?

Comment 8 Bug Zapper 2011-06-02 15:51:33 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Fedora Update System 2011-06-02 19:23:33 UTC
xarchiver-0.5.2-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xarchiver-0.5.2-8.fc14

Comment 10 Fedora Update System 2011-06-02 19:24:09 UTC
xarchiver-0.5.2-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xarchiver-0.5.2-8.fc15

Comment 11 Christoph Wickert 2011-06-02 19:57:49 UTC
(In reply to comment #7)
> Is it patched in / for Fedora 15?

You can read changelogs, can you?

Comment 12 Raphael Groner 2011-06-02 20:27:01 UTC
(In reply to comment #9)
Thanks for applying the patch. XZ support seems to work so far.
I tried also to open xarchiver-0.5.2-8.fc14.x86_64.rpm itself with the same installed package but no success.
I can only speak for Fedora 14.

Comment 13 Christoph Wickert 2011-06-02 20:44:19 UTC
(In reply to comment #6)
> See http://daniel.hozac.com/tmp/xarchiver-0.5.2-rpm2cpio.patch for a simple
> patch that makes it work on RPM-based systems 

Daniel, is anything else but your patch needed?

Comment 14 Steven Usdansky 2011-06-02 22:33:40 UTC
Just installed xarchiver-0.5.2-6.fc15.x86_64. Tested with my file mountie.tar.xz file. I can see the files in the archive, but can't view or extract them.

Comment 15 Fedora Update System 2011-06-03 05:27:48 UTC
Package xarchiver-0.5.2-8.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xarchiver-0.5.2-8.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xarchiver-0.5.2-8.fc15
then log in and leave karma (feedback).

Comment 16 Steven Usdansky 2011-06-03 10:38:12 UTC
Upgraded to xarchiver-0.5.2-8.fc15.x86_64
Still doesn't work. (Anonymous Tester - 2011-06-03 10:34:44)
Additional info:
~/Desktop$ rpm -qa | grep xz
xz-libs-5.0.1-2.fc15.x86_64
xz-5.0.1-2.fc15.x86_64
xz-compat-libs-5.0.1-2.fc15.x86_64

Comment 17 Christoph Wickert 2011-06-09 00:16:50 UTC
Daniel, can you please help us with your patch? I wonder if I missed something?

Comment 18 Christoph Wickert 2011-06-09 08:04:30 UTC
*** Bug 711983 has been marked as a duplicate of this bug. ***

Comment 19 Daniel Hokka Zakrisson 2011-06-09 12:07:30 UTC
Created attachment 503876 [details]
Fixed xz patch

It's a bug in the xz patch. It would treat rpm, lzo, tar, 7zip, lha, and deb as xz too, and fail. This patch should fix that.

Comment 20 Daniel Hokka Zakrisson 2011-06-09 12:11:26 UTC
Note, I didn't fix the memcmp's aside from the missing comparison. They are further incorrect in that they only compare the first 3 bytes, while meaning to pass 7 bytes, but failing and passing 10. Perhaps that is fine though.

Comment 21 Christoph Wickert 2011-06-11 22:47:28 UTC
Yeah. At least the patch works, thanks a lot for that. Frankly speaking I don't want to invest much work into xarchiver as it seems dead.

Comment 22 Raphael Groner 2011-06-12 06:56:28 UTC
I'll use file-roller instead for pragmatic reasons, so I am not interested in a rpm-fixed xarchiver any more.

Comment 23 Wolfgang Ulbrich 2011-06-13 10:04:47 UTC
I 've tested xarchiver-0.5.2-9.fc15.x86_64, with that version it's possible to open and extract a rpm.
Thx for fixing.
But inside thunar the commands 'extract here' or 'extract to' from the right click menu, doesn't work.
That means nothing happens if you try this commands.
But this seems to be a thunar problem.
For me it's no solution to work with file-roller.

[rave@mother ~]$ file-roller 
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not installed

aborting...

I don't want install unnecessary gnome stuff. ;-)

Comment 24 Christoph Wickert 2011-06-13 10:36:07 UTC
(In reply to comment #23)
> But inside thunar the commands 'extract here' or 'extract to' from the right
> click menu, doesn't work.

This is bug 643676, please don't mess everything up.

> [rave@mother ~]$ file-roller 
> GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not
> be saved or shared with other applications.
> 
> GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not
> installed
> 
> aborting...

This is an issue with file-roller. Uninstall file-roller-nautilus. If the problem still occurs, please file a bug against file-roller and cc me.

Comment 25 Fedora Update System 2011-06-24 17:53:22 UTC
xarchiver-0.5.2-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2011-07-03 19:19:16 UTC
xarchiver-0.5.2-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Raphael Groner 2011-07-21 01:14:40 UTC
There's an upstream bug report, propably related to our issue here.

https://bugzilla.xfce.org/show_bug.cgi?id=7825

Comment 28 Christoph Wickert 2011-07-21 06:55:28 UTC
That is not the upstream bug report because Xfce no longer is upstream. Two upstream reports are already mentioned in comment 1 and comment 2.


Note You need to log in before you can comment on or make changes to this bug.