Bug 57755 - Debug files are created in the home directory
Summary: Debug files are created in the home directory
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pine   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-21 00:45 UTC by Pavel Roskin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-21 00:47:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for the specfile (232 bytes, patch)
2001-12-21 00:47 UTC, Pavel Roskin
no flags Details | Diff

Description Pavel Roskin 2001-12-21 00:45:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011219

Description of problem:
Files .pine-debug[1-4] are created in the home directory by pine-4.43. Pine
should be compiled without debugging when it's distributed for the end users.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install pine-4.43-1 from RawHide.
2. Run pine
3. Exit from pine
4. Run ls .pine-debug*
	

Actual Results:  Debug files are listed

Expected Results:  No debug files are created

Additional info:

Debug support is enabled by default.  RedHat used to disable it, by the
Cahngelog in the specfile indicates that the empty DEBUG option was removed
because of the build problems with pine-4.41.

There are no build problems with pine-4.33 when it's configured without
debug support.

Comment 1 Pavel Roskin 2001-12-21 00:47:00 UTC
Created attachment 41149 [details]
Fix for the specfile

Comment 2 Mike A. Harris 2001-12-23 21:19:10 UTC
Fixed in 4.43-2 in rawhide

Thanks for the report, and also for the taking the time to make a patch too!


Note You need to log in before you can comment on or make changes to this bug.