Bug 57756 - The bookmark editor crashes with too many bookmarks
Summary: The bookmark editor crashes with too many bookmarks
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: galeon
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-21 01:56 UTC by ajs
Modified: 2008-05-01 15:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2002-01-25 20:05:23 UTC


Attachments (Terms of Use)

Description ajs 2001-12-21 01:56:00 UTC
Description of Problem:
  If the bookmark.xml file becomes too large (somewhere between 456KB and
  522KB), the bookmark editor will cause galeon to crash.

Version-Release number of selected component (if applicable):
  galeon-0.11.3-2

How Reproducible:
  Always

Steps to Reproduce:
1. Make a big bookmark.xml file
2. Start Galeon
3. Try to edit the bookmarks

Actual Results:
  Galeon dies with
    ** ERROR **: file io-ico.c: line 342 (DecodeHeader): assertion failed:
(State->LineBuf != NULL)
    aborting...
    Aborted
    


Additional Information:
   Adding new bookmarks and viewing existing ones causes no problems, only
   editing.

Comment 1 Christopher Blizzard 2002-01-25 20:05:18 UTC
Do you have a sample bookmarks file you can offer?

Comment 2 ajs 2002-02-02 21:36:57 UTC
I created a test user account so that I could prepare a bookmark file.  The
result is that I can't reproduce the error in the fresh Gnome environment.  I
think now that there is a problem with my Gnome or Galeon configuration
somewhere.  I've tried to rerun the first time Druid in my normal user account,
but that did not help.  Sorry for the false alarm.


Note You need to log in before you can comment on or make changes to this bug.