Bug 57767 - anaconda does not set full_duplex for Dlink DFE-530TX so NFS install randomly hangs (timeout)
anaconda does not set full_duplex for Dlink DFE-530TX so NFS install randomly...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-21 13:40 EST by Patrick Pollet
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 15:16:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Pollet 2001-12-21 13:40:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [fr] (WinNT; I)

Description of problem:
Many PCI cards using the via-rhine driver need  full_duplex=1 option, especially with busy networks. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. kickstart RH7.2 on several machines with DFE 530 net card in the same subnet
2.
3.
	

Actual Results:  The new kickstart shipping with RedHat 7.2 does find the DFE 530 card, request for a driver disk
 and automatically load the via-rhine driver.
So far so good... but no way to set the full_duplex option to 1.

So nfs installation crashed randomly when the card looses the network connection in half duplex mode.

In Redhat 7.1 kickstart, I used to press F2, insert the driver disk, select the via-rhine driver, clicks on "option" and type full_duplex=1 and 
everything was fine...

Now with the automatic detection and loading, no way to set the full_duplex...

I did try to add some lines  in the via-rhine section of the modinfo file of the driver disk such as:
     full_duplex  "1"
     full_duplex  "full_duplex (0=no; 1=yes)

but I never got any success...





Additional info:
Comment 1 Jeremy Katz 2002-01-02 17:05:32 EST
You should be able to put 

device eth via-rhine --opts full_duplex=1

in your kickstart config.
Comment 2 Patrick Pollet 2002-01-03 06:07:44 EST
I did try your suggestion with no success.

the "correct syntax", at least that one that do not give a TypeError in kickstart.py is
   network --device eth0 via-rhine opts full_duplex=1        ( no -- before opts)
but it does not solve the infamous "Transmit timeout problem". It looks like opts parameter is simply ignored .
I also tried network --device eth0 via-rhine options full_duplex=1
No difference...
   I think the problem is with the via-rhine driver. Donald Becker has released a new version (1.08) that use an extra
pci-scan.o  module, but so far these modules do not load on 2.4 Kernels ( bad dependencies...). 
  I give up using  these cards DLINK DFE-530TX cards... ( see http://lhd.zdnet.com/db/dispproduct.php3?DISP?296) 
for many others that have bad opinions on this card... 
  I think you should discontinue supporting the via-rhine driver in KickStart until the driver becomes more reliable.
Comment 3 Jeremy Katz 2002-01-15 15:19:49 EST
No, the device line should be a completely separate line in your kickstart
config, not at the end of the network line.

Note You need to log in before you can comment on or make changes to this bug.