Bug 57770 - Compress the headers for download
Summary: Compress the headers for download
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
(Show other bugs)
Version: RHN Stable
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 77017
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-21 19:21 UTC by Hunter Matthews
Modified: 2007-04-18 16:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-17 19:57:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hunter Matthews 2001-12-21 19:21:51 UTC
Description of Problem:

RHN at least with client 2.7.4 does not compress the rpm 
headers 
before downloading them, as it does with the listPackages info.

Without 
modifing the client, the server could compress the headers and
have the normal cgiwrap 
decompression work by setting the Content-Type
to "application/compressed-octet-
stream"

This is probably only important for modem connected users, as most headers are 
not that large.

Comment 1 Mihai Ibanescu 2001-12-21 19:41:40 UTC
This is a known issue. The compression can't be initiated from the server side
since it would break old clients. The client has to explicitly say it wishes the
headers to be compressed, but this would trigger another bug in python's socket
module.

We should be able to turn compression on for the new clients, though.

Comment 2 Cristian Gafton 2002-07-18 19:26:21 UTC
misa, please take care of this issue

Comment 3 Mihai Ibanescu 2002-07-18 20:07:04 UTC
The header is already a compact binary representation, I will have to run some
benchmarks to see how well a header compresses. listPacakages is a different
beast, its output is XML, and XML compresses well (IIRC, from 100k to 16k).

Comment 4 Todd Warner 2002-09-17 19:32:59 UTC
Header is already a compact binary representation...

Shall we close this???

Comment 5 Hunter Matthews 2002-09-17 19:57:08 UTC
Sure (it was a suggestion, not a bug report) In playing around here, there's
_is_ an advantage to compressing the headers, but it would only be noticable on
modem lines.


Note You need to log in before you can comment on or make changes to this bug.