Bug 577708 - Black screen during graphical kickstart install
Black screen during graphical kickstart install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 582590 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker 579653 579654
  Show dependency treegraph
 
Reported: 2010-03-28 22:52 EDT by Liam Li
Modified: 2014-09-30 19:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-13.38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 579653 579654 (view as bug list)
Environment:
Last Closed: 2010-05-03 15:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ks.cfg (1.10 KB, text/plain)
2010-03-28 22:52 EDT, Liam Li
no flags Details
anaconda.log (3.68 KB, text/plain)
2010-03-28 23:04 EDT, Liam Li
no flags Details
X.log (21.58 KB, text/plain)
2010-03-28 23:05 EDT, Liam Li
no flags Details
other logs (110.00 KB, application/x-tar)
2010-03-28 23:05 EDT, Liam Li
no flags Details
X.log from virt DVD install (works) (21.52 KB, application/octet-stream)
2010-03-29 09:19 EDT, James Laska
no flags Details
X.log from virt DVD kickstart install (fails) (21.55 KB, text/plain)
2010-03-29 09:20 EDT, James Laska
no flags Details

  None (edit)
Description Liam Li 2010-03-28 22:52:21 EDT
Created attachment 403155 [details]
ks.cfg

Description of problem:
Install F13 beta RC1 with a graphical kickstart, after print "Running anaconda 13.37", the screen becomes blank,X was failed to start.If install with text mode, install will be successful. This happens on both real and virtual machine. I attached the VM's log below.

Version-Release number of selected component (if applicable):
anaconda 13.37

How reproducible:
100%

Steps to Reproduce:
1.boot with both F13 beta RC1 netboot.iso or DVD.iso in KVM or CD/DVD in real machine
2. input ks=http://server/to/ks.cfg  grub command line
3. continue the install
Comment 1 Liam Li 2010-03-28 23:04:29 EDT
Created attachment 403156 [details]
anaconda.log
Comment 2 Liam Li 2010-03-28 23:05:07 EDT
Created attachment 403157 [details]
X.log
Comment 3 Liam Li 2010-03-28 23:05:56 EDT
Created attachment 403158 [details]
other logs
Comment 4 James Laska 2010-03-29 08:39:26 EDT
I've reproduced this failure in both a known working virt guest, and on bare
metal hardware.  In both cases, I am booting the DVD and providing a link to a
kickstart file (http://jlaska.fedoraproject.org/ks.cfg).

If I boot without the kickstart file ... X starts without problems.

If I boot with the kickstart file ... X fails to start as indicated in Liam's
attached files.

= anaconda.log =

02:26:45,341 WARNING anaconda.stdout:  X startup failed, falling back to text
mode

= X.log =

[    64.383] (II) XINPUT: Adding extended input device ""Macintosh mouse button
emulation"" (type: MOUSE)
[    64.383] (II) "Macintosh mouse button emulation": initialized for relative
axes.
[    64.383] (II) config/udev: Adding input device "Macintosh mouse button
emulation" (/dev/input/mouse0)
[    64.383] (EE) No input driver/identifier specified (ignoring)
[  2019.006] (II) AIGLX: Suspending AIGLX clients for VT switch

I have a suspicion that there is some interaction with anaconda and X that
isn't working problem when starting a kickstart graphical install.
Comment 5 James Laska 2010-03-29 09:19:18 EDT
Created attachment 403290 [details]
X.log from virt DVD install (works)
Comment 6 James Laska 2010-03-29 09:20:12 EDT
Created attachment 403291 [details]
X.log from virt DVD kickstart install (fails)

I've compared the /tmp/X.log from a working graphical DVD install, and from an attempted graphical kickstart DVD install.  Note, I've removed the leading timestamp from the logs to make comparing output easier.  There is no difference in the /tmp/X.log between the working and failing cases.

This makes me believe there might be some interaction in the installer space?
Comment 7 James Laska 2010-03-29 09:35:16 EDT
NOTE: this isn't specific to DVD installs.  I can recreate this problem doing PXEboot installs.
Comment 8 James Laska 2010-03-29 14:21:32 EDT
Chris Lumens directed me to a recent thread on anaconda-devel that might account for this problem.  See https://www.redhat.com/archives/anaconda-devel-list/2010-February/msg00364.html

As such, I created an updates.img with the proposed patch from the mail above.  This resolves the reported problem!  If you'd like to test, use http://jlaska.fedorapeople.org/updates-577708.img
Comment 9 James Laska 2010-03-29 16:12:11 EDT
Spoke with release engineering (jkeating) and development (dlehman), everyone agreed that we can document this issue in Common_F13_Bugs and address this post-beta.  This issue appears to affect only graphical kickstart installs.  The install progresses per the instructions in the kickstart file, however the user may not see if any problems have surfaced.  

Until this is resolved recommended workarounds are:
 1. Perform graphical kickstart installs using the updates.img noted in comment#8
 2. Perform graphical kickstart installs using VNC
 3. Perform graphical kickstart installs using text-mode

Adding keyword CommonBugs to note this on https://fedoraproject.org/wiki/Common_F13_bugs
Comment 10 James Laska 2010-03-30 12:58:42 EDT
Just realized that this will also impact preupgrade users.  Support for preupgrade is on the Beta release criteria (https://fedoraproject.org/wiki/Fedora_13_Beta_Release_Criteria).
Comment 11 He Rui 2010-03-31 05:06:45 EDT
Reproduced in anaconda 13.37.1 of F13 Beta RC2
Comment 12 James Laska 2010-03-31 09:48:59 EDT
Adding for consideration as a F-13-Beta blocking issue as this will most likely impact preupgrade users.
Comment 13 Ales Kozumplik 2010-03-31 10:14:56 EDT
Fixed for Fedora 13 by c773081e75b049256c1377c1f9a702a1a6cc9f12.
Comment 14 Ales Kozumplik 2010-03-31 10:36:23 EDT
The bug will be moved to modified once the beta blocker decision is made so the fixed-in version can be determined.
Comment 15 James Laska 2010-04-06 10:37:03 EDT
(In reply to comment #14)
> The bug will be moved to modified once the beta blocker decision is made so the
> fixed-in version can be determined.    

Ales, this issue can be fixed in F-13 after F13Beta.  I don't know if you have a branch in anaconda for post f13beta changes.
Comment 16 James Laska 2010-04-19 09:53:59 EDT
*** Bug 582590 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2010-05-03 14:58:31 EDT
can someone please test and confirm that this is fixed in TC1? Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 James Laska 2010-05-03 15:13:50 EDT
Confirmed during Preupgrade test day.
Comment 19 James Laska 2010-05-03 15:15:34 EDT
(In reply to comment #18)
> Confirmed during Preupgrade test day.    

Which used anaconda-13.38-1 (http://git.fedorahosted.org/git?p=anaconda.git;a=commit;h=c773081e75b049256c1377c1f9a702a1a6cc9f12).
Comment 20 James Laska 2010-05-03 15:16:08 EDT
Closing, please feel free to reopen this issue if the reported problem is no longer addressed.
Comment 21 Liam Li 2010-05-03 23:34:43 EDT
tested on anaconda 13.39, fixed.

Note You need to log in before you can comment on or make changes to this bug.