This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57772 - libGL not loading libpthread.so
libGL not loading libpthread.so
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-21 15:17 EST by Thomas Dodd
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 18:57:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Dodd 2001-12-21 15:17:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.6+) Gecko/20011211

Description of problem:
I build XFree86-4.1.99.2-0.2.3 from srpm.
Installed nodeps because of Mesa-demos, the only failed
dep when removing Mesa. Run glxinf or other OpenGL app.
Fails to find pthread_key_create.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.glxinfo
2.
3.
	

Actual Results:  glxinfo: relocation error: /usr/X11R6/lib/libGL.so.1:
undefined symbol: pthread_key_create

Expected Results:  glxinfo show status of glx/OpenGL accelleration


Additional info:

ldd -r /usr/bin/glxinfo
undefined symbols for: pthread_key_create, pthread_getspecific, and
pthread_setspecific all in /lib/X11R6/lib/libGL.so.1

libGL.so.1 is from XFree86-libs-4.1.99.2-0.2.3
glibc-2.2.4-19.3 (i686 version installed, Athlon CPU used)

setting LD_PRELOAD=/lib/i686/libpthread-0.9.so is a work around.
Why isn't ld.so loading libpthread?

XFree86-4.1.0 (from testing and rawhide) with external Mesa
worked fine.
Comment 1 Bill Crawford 2001-12-31 19:18:17 EST
I saw this with the "bleeding-edge" packages from your ftp space, Mike, but only
with glxinfo and gears so far.  Oddly enough all the xscreensaver GL hacks are
working fine.  Likewise xlock is OK.

[bill@desktop bill]$ glxinfo 
glxinfo: relocation error: /usr/X11R6/lib/libGL.so.1: undefined symbol:
pthread_key_create
[bill@desktop bill]$ gears
gears: relocation error: /usr/X11R6/lib/libGL.so.1: undefined symbol:
pthread_key_create

Unreal Tournament still works fine, too, though.  So it looks like just the
stuff that was built as part of XFree86?
Comment 2 Mike A. Harris 2002-01-24 18:57:00 EST
Mesa for XFree86 4.1.0 and earlier was built without pthreads
on purpose, however I do not recall why exactly.

Whatever the problem is here, wont be fixed in 4.1.0 releases
now at this point.  Up until just recently, the XFree86 in rawhide
was bogus.  It was just inherited from prior tree builds until 4.2.0
came out.  4.2.0 is now in the rawhide tree.  Can you please try
it and let me know if the problem you are experiencing persists.

Please update the bug report with any new pertinent information.

Note You need to log in before you can comment on or make changes to this bug.