Bug 57777 - XFree86-3.3.6-29 crashes when starting 6.2 on an alpha
XFree86-3.3.6-29 crashes when starting 6.2 on an alpha
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
alphaev6 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-21 20:22 EST by John R. booker
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-21 21:09:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John R. booker 2001-12-21 20:22:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.1 i686)

Description of problem:
After installing all security patches to date (12/20/01) for RH6.2 on my
Compaq XP-1000 Alpha machine with Gloria Synergy 8MB card and P-75
mulit-synch monitor, I was unable to boot up in graphical mode. The problem
is that X cannot set the default font path 'unix/:1' and cannot open the
default font 'fixed'. Reinstalling Free86-3.3.6-20 restores machine to full
function. For "29",  I installed all rpms in the update notice and for "20"
I re-installed all rpms using --force in the 6.2 release cdrom. I tried
using Xconfigurator with "29" and it worked normally including the display
screen at the end that asks you whether you can see the square in the
center of the screen. An important clue is that when I boot in text mode
with "20" installed, then install "29" and finally do a "startx", the X
server starts properly. I think this implies that a system pararameter is
being properly set PRIOR to startx by "20" and is being used correctly by
"29". However, when I reboot, "29" fails again and I have to re-install
"20" to use graphical mode. Thus "29" is re-setting the parameter to an
incorrect value (or perhaps not setting it all) prior to the startx
command. The workaround is to continue to use "20" with whatever security
issues are involved.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install all security-related patches to RH6.2 on an Alpha including
latest kernel. 
2. Upgrade XFree86-3.3.6-20 to XFree86-3.3.6-29
2. A: reboot in graphical mode OR
    B: reboot in text mode, login as root and then use command startx



Actual Results:  A: Monitor never syncs, but keeps trying OR
B: Get error message and monitor is ready for a new command

Expected Results:  A: the graphical login screen should have come up OR
B: gnome should have started.

Additional info:

failed to set default font path 'unix/:-1'
Fatal server error:
could not open default font 'fixed'
X connection to :0.0 broken (explicit kill or server shutdown)
Comment 1 John R. booker 2001-12-21 21:06:46 EST
XFree86's output before error message (I have deleted not relevant stuff)

XFree86 Version 3.3.6a / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: April 19, 2001
Operating System: Linux 2.4.2-2smp alpha [ELF]
Configured drivers:
  GLINT: accelerated server for 3DLabs GLINT graphics adapters
(Patchlevel 0)
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "en_US"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) Mouse: 3 button emulation (timeout: 50ms)
(**) GLINT: Graphics device ID: "TVP4020 [Permedia 2]"
(**) GLINT: Monitor ID: "Compaq P75 Monitor"Warning: The directory
"/usr/X11R6/lib/X11/fonts/TrueType" does not exist.
         Entry deleted from font path.
(**) FontPath set to "unix/:-1"
(--) GLINT: found TI chip GLINT Permedia 2 at card #13 func #0 with base
0x9020000
(--) GLINT: Framebuffer address at 0xa000000
(**) GLINT: videoram : 8192k(--) GLINT: Fitted Memory type is : SGRAM
(--) GLINT: VGA core is : Enabled
(--) GLINT: Maximum allowed dot-clock: 230.000 MHz
(**) GLINT: Mode "1024x768": mode clock = 115.500
(--) GLINT: Using XAA (XFree86 Acceleration Architecture)
(--) GLINT: XAA: Solid filled rectangles
(--) GLINT: XAA: Screen-to-screen copy
(--) GLINT: XAA: Using 8 128x128 areas for pixmap caching(--) GLINT: XAA:
Caching tiles and non-transparent stipples
(--) GLINT: XAA: Horizontal and vertical lines and segments

Then the error message:
_FontTransSocketUnixConnect: Can't  connect: errno = 61
failed to set default font path 'unix/:-1'
Fatal server error:
could not open default font 'fixed'



Comment 2 Mike A. Harris 2001-12-21 21:41:44 EST
I am unable to reproduce this problem on my Alpha box here.  Most
of these types of problems are configuration problems.  It is strongly
recommended that you upgrade to Red Hat Linux 7.1 for Alpha, as the
XFree86 support is much better as well.

Note You need to log in before you can comment on or make changes to this bug.