Bug 57784 - anaconda unable to handle linear/append array on upgrade and crashes
Summary: anaconda unable to handle linear/append array on upgrade and crashes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2001-12-22 20:01 UTC by ferry
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 22:19:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
saved with installer (23.60 KB, text/plain)
2001-12-22 20:01 UTC, ferry
no flags Details
As requested: my /etc/raidtab (253 bytes, text/plain)
2002-01-02 22:25 UTC, ferry
no flags Details
Tried it again, this time it worked: a dump from the errors I got (7.07 KB, text/plain)
2002-12-11 20:48 UTC, ferry
no flags Details

Description ferry 2001-12-22 20:01:13 UTC
Description of Problem: Installer generates a  errormessage and dumps a
trace. Says It should be sumbmitted to this location.


Version-Release number of selected component (if applicable):


How Reproducible: every time


Steps to Reproduce:
1.boot from CD
2.choose expert mode
3.us, uk, no mouse text mode

Actual Results:
anaconda exits and the system is being shutdown

Expected Results:
It should install RH7.2

Additional Information:
	
See trace

Comment 1 ferry 2001-12-22 20:01:51 UTC
Created attachment 41267 [details]
saved with installer

Comment 2 ferry 2001-12-22 20:24:02 UTC
I'm upgrading from RH7.0. It can also be reproduced using the normal text
installation procedure => I am unable to install RH7.2.

Comment 3 Jeremy Katz 2002-01-02 22:11:35 UTC
What does your /etc/raidtab look like?

Comment 4 ferry 2002-01-02 22:25:16 UTC
Created attachment 41654 [details]
As requested: my /etc/raidtab

Comment 5 ferry 2002-01-05 22:37:48 UTC
Eventually I installed RH7.2 using a workaround. At the bootpromp I typed the
following:

boot: expert hde=none hdg=none

This way I prevented the RH kernel to discover my two raid0 (striping)
partitions residing on these drives. Of course this was only possible due to the
fact that I didn't store OS related stuff on those drives. The install went
flawless after that. I also removed my /etc/raidtab but I'm not sure whether
that matters.

Comment 6 Jeremy Katz 2002-04-08 22:49:44 UTC
msw committed something that should fix this to CVS

Comment 7 Michael Fulbright 2002-04-09 20:35:12 UTC
This works for me now.

Comment 8 ferry 2002-12-11 20:35:33 UTC
Trying to install RH8.0 now with a similar (but not the same) error on a similar
setup. Install exits after selecting a partitioning method. 

Can't supply an error log/trace/dump since a write to floppy didn't work.
Copying by hand:

in file "usr/lib/anaconda/partRequests.py, line 604 
Valuerror: Invalid raidlevel in Raidrequest.getActualSize

Have to say that the summary was wrong all the time since it is not (and never
has been) a RAID-0 setup but just a linear or append joining of two partitions
(as can be seen from my raidtab). Sorry about that.

Comment 9 ferry 2002-12-11 20:48:06 UTC
Created attachment 88464 [details]
Tried it again, this time it worked: a dump from the errors I got

Comment 10 Matt Wilson 2002-12-15 00:44:18 UTC
Wild - it's coming up as RAID-1


Comment 11 Matt Wilson 2002-12-15 00:44:54 UTC
Adding CC: for katzj

Comment 12 Jeremy Katz 2005-02-01 22:19:47 UTC
This should be better in newer releases.


Note You need to log in before you can comment on or make changes to this bug.