Bug 57788 - Messed up font configuration after an update
Messed up font configuration after an update
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-22 18:40 EST by Michal Jaegermann
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 00:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-12-22 18:40:52 EST
Description of Problem:

I have seen manifestations of this problem not only on alpha and with
other releases 4.1.0-14 but this has to be filed somewhere. :-)
After an update X server does not want to start because "fixed" font
cannot be found.  A closer investigation reveals that in various
subdirectories of /usr/X11R6/lib/X11/fonts/ files like 'fonts.dir'
and/or 'encodings.dir' are missing apparently at random.

Various font packages execute the same postinstallation script which
looks like this:

  for fontdir in 100dpi 75dpi CID Speedo Type1 misc \
                 latin2/{Type1} ;do
    umask 133;/usr/X11R6/bin/mkfontdir -e \
    /usr/X11R6/lib/X11/fonts/encodings -e \    
    /usr/X11R6/lib/X11/fonts/encodings/large \
    /usr/X11R6/lib/X11/fonts/$fontdir || :
    /usr/sbin/chkfontpath -q -a /usr/X11R6/lib/X11/fonts/$fontdir || :
  done

Executing "manually" just mkfontdir-part of the loop above restores
sanity immediately.  Is this 'chkfontpath' responsible for the resulting
mess?  On this particular test installation the following packages
were really used in an update:

XFree86-100dpi-fonts-4.1.0-14.alpha.rpm
XFree86-75dpi-fonts-4.1.0-14.alpha.rpm
XFree86-cyrillic-fonts-4.1.0-14.alpha.rpm
XFree86-ISO8859-15-100dpi-fonts-4.1.0-14.alpha.rpm
XFree86-ISO8859-15-75dpi-fonts-4.1.0-14.alpha.rpm
XFree86-ISO8859-2-100dpi-fonts-4.1.0-14.alpha.rpm
XFree86-ISO8859-2-75dpi-fonts-4.1.0-14.alpha.rpm
XFree86-ISO8859-9-100dpi-fonts-4.1.0-14.alpha.rpm
XFree86-ISO8859-9-75dpi-fonts-4.1.0-14.alpha.rpm
Comment 1 Mike A. Harris 2002-01-23 15:29:53 EST
Once X is updated, both xfs and XFree86 need to be restarted and
everything should work fine.  I can't reproduce the problem you're
describing.
Comment 2 Michal Jaegermann 2002-01-23 16:53:13 EST
Well, sure, but restarting X and xfs does not help with recreating various
missing 'fonts.dir' and encoding files.  It was actually hard to notice
that something is funny without restarting xfs.

I have suspicions, but not a "smoking gun", that the problem is some mixup
during updates when fonts with various encodings are installed.  When you
tried to reproduce did you have only iso8859-1 fonts on a machine or some
other ones as well?
Comment 3 Mike A. Harris 2002-08-08 07:00:50 EDT
Problem is not reproduceable in rawhide currently.  Closing as
fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.