Bug 577896 - xf86OpenConsole; VT_WAITACTIVE failed after KMS with Intel
xf86OpenConsole; VT_WAITACTIVE failed after KMS with Intel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-03-29 12:01 EDT by Matt Domsch
Modified: 2010-04-20 15:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 15:29:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failing Xorg.0.log (7.17 KB, text/plain)
2010-03-29 12:01 EDT, Matt Domsch
no flags Details
working Xorg.0.log (52.89 KB, text/plain)
2010-03-29 12:01 EDT, Matt Domsch
no flags Details
Failing Xorg.0.log (7.24 KB, text/plain)
2010-04-06 11:53 EDT, Tom London
no flags Details

  None (edit)
Description Matt Domsch 2010-03-29 12:01:03 EDT
Created attachment 403317 [details]
failing Xorg.0.log

Description of problem:
Fedora 13 (pre-beta).  Booting using KMS succeeds, plymouth displays the graphical building Fedora logo, then system hangs without starting X.

Removing 'rhgb quiet' from kernel command line, system boots without plymouth, and X starts as expected.

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
appears in Xorg.0.log

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel -2.10.0-4.fc13.x86_64
xorg-x11-server-Xorg-1.7.99.902-3.20100319.fc13.x86_64

System is a Dell XPS M1330 laptop with Intel graphics.

How reproducible:
always

Steps to Reproduce:
1. boot with 'rhgb quiet' on kernel command line
  
Actual results:
no X

Expected results:
X
Comment 1 Matt Domsch 2010-03-29 12:01:58 EDT
Created attachment 403318 [details]
working Xorg.0.log

when removing 'rhgb quiet' from the kernel command line.
Comment 2 Orion Poplawski 2010-04-01 15:53:37 EDT
Also seeing this on a Fujitsu LifeBook S6510 with Intel GM965/GL960 graphics controller and kdm with F13 Beta RC3.

kernel-2.6.33.1-19.fc13.x86_64
xorg-x11-server-Xorg-1.7.99.902-3.20100319.fc13.x86_64
xorg-x11-drv-intel-2.10.0-4.fc13.x86_64
kdm-4.4.1-2.fc13.x86_64
Comment 3 Tom London 2010-04-06 11:53:22 EDT
Created attachment 404735 [details]
Failing Xorg.0.log

I'm seeing this also.

Seems to work more reliably if I hit 'ESC' during plymouth to get boot messages.

Running:

[tbl@tlondon ~]$ rpm -qa xorg-x11-server\* xorg-x11-drv-intel
xorg-x11-server-common-1.7.99.902-3.20100319.fc14.x86_64
xorg-x11-server-utils-7.4-16.fc14.x86_64
xorg-x11-drv-intel-2.10.0-4.fc13.x86_64
xorg-x11-server-Xorg-1.7.99.902-3.20100319.fc14.x86_64
[tbl@tlondon ~]$ uname -a
Linux tlondon.innopath.com 2.6.34-0.28.rc3.git3.fc14.x86_64 #1 SMP Mon Apr 5 17:05:31 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
[tbl@tlondon ~]$ 

I also am seeing this in /var/log/messages:

Apr  6 08:26:05 tlondon kernel: [drm:i915_gem_madvise_ioctl] *ERROR* Attempted i915_gem_madvise_ioctl() on a pinned object

and

Apr  6 08:24:25 tlondon gdm-binary[1663]: GLib-GObject-WARNING: IA__g_object_set_valist: object class `GdmStaticDisplay' has no property named `force-active-vt'
Comment 4 Orion Poplawski 2010-04-06 18:43:47 EDT
Works for me with gdm, but not kdm.
Comment 5 Orion Poplawski 2010-04-06 18:45:47 EDT
Also, I'm stuck on the plymouth boot graphic when X crashes like this.  I cannot ctrl-alt-Fn to another tty.
Comment 6 Tom London 2010-04-07 09:24:53 EDT
Appears that updating to 

gdm-2.30.0-2.fc14.x86_64

"fixes this for me".....

[changelog for this says:
 	* Tue Apr 06 2010 Ray Strode <rstrode@redhat.com> 2.30.0-2 - Update plymouth patch to work with 0.8.1 
]
Comment 7 Adam Jackson 2010-04-20 15:29:59 EDT
Yeah, pretty sure this was a gdm bug.  Please reopen if you can reproduce with 2.30.0-2 or later.

Note You need to log in before you can comment on or make changes to this bug.