Bug 577953 - Full-screen java applet behavior changed
Full-screen java applet behavior changed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jon VanAlten
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-29 16:23 EDT by Bob Mader
Modified: 2010-12-02 15:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-02 15:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Mader 2010-03-29 16:23:21 EDT
Description of problem: 

After upgrading to java-1.6.0-openjdk-1.6.0.0-34.b17.fc12, Java applets that support full-screen mode no longer take up the full screen.  Instead, the Gnome application bar and process bar remain visible. 

I observed this trying to use the full-screen mode of HOBsoft's HOBlink JWT, a Java applet-based RDP client. I have confirmed that this also occurs with other different full-screen Java applets. 


Version-Release number of selected component (if applicable):

worked correctly with java-1.6.0-openjdk-1.6.0.0-33.b16.fc12

problem observed with java-1.6.0-openjdk-1.6.0.0-34.b17.fc12 (or later)


How reproducible:

Observe changed full-screen behavior of a Java applet.


Steps to Reproduce:

1. Start with java-1.6.0-openjdk-1.6.0.0-33.b16.fc12 or earlier installed

2. Run Firefox and navigate to http://evil.hackademix.net/fullscreen/applet.html

3. After the java applet launches, amusing messages are displayed in full-screen mode (see additional info below)

3. Observe the full-screen applet is taking the whole screen

4. Upgrade to java-1.6.0-openjdk-1.6.0.0-34.b17.fc12 (or later)

5. Restart Firefox and repeat steps 2-3

6. Observe Gnome GUI elements still visible. 

  
Actual results:

Gnome GUI elements still visible when running full-screen applet


Expected results:

Full-screen applet should take over the whole screen


Additional info:

The Java applet example displays the message PWND. Don't panic, just click a few times and it will exit. Details and source code can be found at  http://hackademix.net/2007/08/07/java-evil-popups/.

HOBlink JWT is an commercial Java applet-based RDP client used in a number of remote access products. Details at http://www.hobsoft.com/products/connect/jwt.jsp. It is very desirable to be able to achieve true full-screen mode when working with a remote desktop.
Comment 1 Deepak Bhole 2010-03-30 14:08:29 EDT
This appears to be an issue in OpenJDK itself (rather than it being plugin specific). Re-assigning.
Comment 2 Andrew John Hughes 2010-04-06 14:41:20 EDT
It's a bug in Metacity rather than OpenJDK; see https://bugzilla.gnome.org/show_bug.cgi?id=405269 and Sun's bug http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6514512
Comment 3 Bob Mader 2010-07-05 21:21:50 EDT
Problem also observed in Fedora 13 with:

java-1.6.0-openjdk-1.6.0.0-41.b18.fc13.i686
metacity-2.30.0-2.fc13.i686
Comment 4 Jon VanAlten 2010-07-15 14:01:45 EDT
This has been fixed upstream.  It is a metacity issue, but they've indicated for a long time that because it is not broken spec they are not likely to change it.  IcedTea did patch it in the past, but removed it in part because their upstream (OpenJDK) did not agree with it.  But, it is not acceptable for full screen java windows to be obstructed by panel elements.  So, being between a rock and a hard place, the patch has been added back to IcedTea: http://icedtea.classpath.org/hg/icedtea6/rev/5719610f7230

Coming soon (hopefully) to a fedora package near you!
Comment 5 Andrew John Hughes 2010-07-16 12:36:08 EDT
The patch has been backported to the stable 1.7 and 1.8 branches of IcedTea6 too, so it should ripple through to a package sooner or later, as Jon says.
Comment 6 Bob Mader 2010-12-02 15:49:09 EST
I just tested with Fedora 14 and the issue appears to be fixed. Thanks all for pushing this through!

java-1.6.0-openjdk-1.6.0.0-49.1.9.2.fc14.i686
metacity-2.30.3-1.fc14.i686
Comment 7 Omair Majid 2010-12-02 15:51:44 EST
Confirmed that this is fixed on Fedora 13 as well with java-1.6.0-openjdk-1.6.0.0-46.1.8.3.fc13.x86_64.

Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.