Bug 57805 - restore from HP Colorado IDE tape drive gives "tape read errors"
restore from HP Colorado IDE tape drive gives "tape read errors"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
7.1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-23 17:50 EST by George Loyer
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 03:24:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George Loyer 2001-12-23 17:50:44 EST
Description of Problem: Any restore operation on a dump file stored on an 
HP Colorado 20Gb IDE tape drive gives a "tape read error" and fails.


Version-Release number of selected component (if applicable): HP Colorado 
20GB rev 4.01, RH 7.1


How Reproducible: every time


Steps to Reproduce:
1. /sbin/dump -0u -f /dev/nht0 /home >> successfully dumps to tape
2. mt -f /dev/nht0 tell >> At block 227181 (for example)
3. mt -f /dev/nht0 rewind
4. /sbin/restore -i -f /dev/nht0 (or any other restore option) >> "tape 
read error: Input/output error" and return to prompt. no tape movement 
happens on the restore.

/var/log/messages:
Dec 23 13:56:49 localhost kernel: ide-tape: Reached idetape_chrdev_open
Dec 23 13:56:49 localhost kernel: ide-tape: ht0: I/O error, pc =  8, key 
=  5, asc = 2c, ascq =  0

Actual Results:


Expected Results:


Additional Information:
Comment 1 George Loyer 2001-12-23 18:15:08 EST
Just tested tar in the same way. Tar to tape works fine, tar read from tape 
fails:
at the command line, error is:
[root@localhost /]# tar tvf /dev/nht0
tar: /dev/nht0: Cannot read: Input/output error
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now

Error in /var/log/messages is identical to restore failure. This definitely 
worked in earlier version (6.2). I hadn't used dump/restore under that version.
Comment 2 Mike A. Harris 2002-01-18 03:24:09 EST
Please make sure your system is updated with all Red Hat Linux erratum
updates, including dump and the kernel.  Update the report please
after updating to let me know the status of your results.

Thanks
Comment 3 Mike A. Harris 2002-02-11 08:25:57 EST
Problem reported solved in the rawhide version of dump.

Note You need to log in before you can comment on or make changes to this bug.