Bug 578060 - Dracut cannot resolve dns and needs numeric ip address for nfs root
Summary: Dracut cannot resolve dns and needs numeric ip address for nfs root
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-30 06:12 UTC by Ian Dall
Modified: 2010-10-30 23:39 UTC (History)
4 users (show)

Fixed In Version: dracut-005-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of: 537217
Environment:
Last Closed: 2010-10-27 22:54:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Patch to parse /etc/nsswitch.conf properly. (944 bytes, patch)
2010-03-30 06:12 UTC, Ian Dall
no flags Details | Diff

Description Ian Dall 2010-03-30 06:12:30 UTC
Created attachment 403412 [details]
Patch to parse /etc/nsswitch.conf properly.

+++ This bug was initially created as a clone of Bug #537217 +++

I'm PXE booting systems with an NFS root filesystem.  What I would expect to be able to do is something like:

append initrd=f12-x86_64-net/initrd.img root=nfs:fileserver:/potatoes/f12-x86_64-net

which fails.

Booting with rdbreak set and using the emergency shell and running

  ip -r route

shows ip is unable to resolve the name of the default route.

The problem is that on the ram disk, /lib/libnss_* includes lib/libnss_files-2.11.1.so,  lib/libnss_nisplus-2.11.1.so, lib/libnss_files.so.2 and      lib/libnss_nisplus.so.2, but NOT lib/libnss_mdns4_minimal.so.2 or lib/libnss_dns-2.11.1.so.

This in turn is due to the dracut nfs install mishandling the NOFOUND tag when it parses /etc/nsswitch.conf.

There will be no problem experienced if NOFOUND is not used, but the distributed nsswitch.conf does use NOTFOUND.

Patch attched.

Comment 1 Fedora Update System 2010-09-23 15:31:07 UTC
dracut-005-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/dracut-005-4.fc13

Comment 2 Fedora Update System 2010-09-23 15:32:36 UTC
dracut-005-4.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/dracut-005-4.fc12

Comment 3 Fedora Update System 2010-09-24 20:38:17 UTC
dracut-005-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/dracut-005-4.fc12

Comment 4 Fedora Update System 2010-10-27 22:53:03 UTC
dracut-005-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2010-10-30 23:37:45 UTC
dracut-005-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.