Bug 578097 - dhclient did not add any new address in IA option
Summary: dhclient did not add any new address in IA option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 578098
TreeView+ depends on / blocked
 
Reported: 2010-03-30 08:14 UTC by Yang Ren
Modified: 2010-05-22 01:49 UTC (History)
2 users (show)

Fixed In Version: dhcp-4.1.1-16.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 578098 (view as bug list)
Environment:
Last Closed: 2010-05-22 01:44:51 UTC


Attachments (Terms of Use)
dhclient-script (22.50 KB, text/plain)
2010-04-20 16:09 UTC, Jiri Popelka
no flags Details
dhclient-script debug file (456 bytes, text/plain)
2010-04-21 03:11 UTC, Yang Ren
no flags Details

Description Yang Ren 2010-03-30 08:14:08 UTC
Description of problem:
rfc3315 18.1.8
   If the Reply was received in response to a Solicit (with a Rapid
   Commit option), Request, Renew or Rebind message, the client Adds
   any new addresses in the IA option to the IA as recorded by the 
   client.
.....
.....
.....

There is a test send reply msg to a renew msg with two addresses in IA option.
Then it try to send echo request to both two address.

The client did not reply with the second address.

Version-Release number of selected component (if applicable):
dhclient-4.1.1-13.fc12

How reproducible:
Alwasy

Steps to Reproduce:
1.Start a server
2.during msg exchange send a reply with at lease two addresses in IA option.
3. ping all these addresses
  
Actual results:
client reply the first address. And did not receive echo reply from second address

Expected results:
got echo reply for all these addresses

Additional info:

Comment 1 Jiri Popelka 2010-04-01 07:30:50 UTC
Hi, can you show me the server configuration file? Thanks

Comment 2 Yang Ren 2010-04-01 07:49:50 UTC
hmm... Server is not our software. 
test suite pretend the server and send the package directly.

U may want to have a look at the test result page.
http://focus.bne.redhat.com/~ryang/ipv6ready/DHCPv6_Self_Test_P2_1_1_0_client_latest/rfc3315/67.html

Comment 3 Jiri Popelka 2010-04-01 09:17:04 UTC
Yang, do you remember if you saw this problem also with dhclient prior to dhclient-4.1.1-12.fc12 ? I just want to be sure, that this problem is not caused by fixing the bug #559147.

Comment 4 Yang Ren 2010-04-02 02:11:14 UTC
The test failed in all previous version. So I think it's caused by fix 559147.

Comment 5 Yang Ren 2010-04-06 10:09:20 UTC
I think this bug is not caused by fixing #559147.

Comment 6 Jiri Popelka 2010-04-20 16:09:09 UTC
Created attachment 407864 [details]
dhclient-script

Hi Yang.

Can you do this steps on client machine:
1) Replace the /sbin/dhclient-script file with this attached one.
2) Make sure it is executable (chmod a+x /sbin/dhclient-script).

3) Run the tests again.

4) There should be dhclient-script.debug file in /tmp directory. If you find it, please attach it here.

5) And of course let me know if the new dhclient-script helped to solve this bug.

Thanks

Comment 7 Yang Ren 2010-04-21 03:11:27 UTC
Created attachment 407971 [details]
dhclient-script debug file

Comment 8 Yang Ren 2010-04-21 03:14:49 UTC
Hi J
   
    Wonderful! dhclient-script u attached fix this problem. I attach the debug file here.

    In order to avoid regression I'm running whole test again now.

    btw I'm testing dhclient-4.1.1-14.fc12.x86_64

Thanks

Comment 9 Fedora Update System 2010-04-21 15:14:50 UTC
dhcp-4.1.1-17.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-17.fc13

Comment 10 Fedora Update System 2010-04-21 15:23:01 UTC
dhcp-4.1.1-15.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-15.fc12

Comment 11 Fedora Update System 2010-04-22 22:53:57 UTC
dhcp-4.1.1-15.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-15.fc12

Comment 12 Yang Ren 2010-04-23 07:33:26 UTC
verified in dhcp-4.1.1-15.fc12

Comment 13 Fedora Update System 2010-04-30 17:10:02 UTC
dhcp-4.1.1-16.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-16.fc12

Comment 14 Yang Ren 2010-05-04 04:47:44 UTC
verified in dhcp-4.1.1-16.fc12

Comment 15 Fedora Update System 2010-05-22 01:44:37 UTC
dhcp-4.1.1-16.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-05-22 01:49:44 UTC
dhcp-4.1.1-21.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.