Bug 5781 - Can't upgrade, Mounting error : Error Mounting ext2 filesystem on hda3: Invalid argument.
Can't upgrade, Mounting error : Error Mounting ext2 filesystem on hda3: Inval...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 13:46 EDT by Stijn Jonker
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-21 12:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stijn Jonker 1999-10-09 13:46:34 EDT
Hello,

When i try to upgrade my Comapq Armada 7800 from RH 6.0 to
RH6.1. I get the following error about hda3 in a popup
window.

Error Mounting ext2 filesystem on hda3: Invalid argument.

On tty4 is the following error:
VFS: Can't find an ext2 filesystem on dev ide0(3,3).


From then on the installer just halts and i can't continue.
I tried expert and textmode. I tried putting hda3 in the
fstab WITH the fs type ntfs but it didn't help.

Here is the output of fdisk:

[root@lt-sjr joker]# fdisk /dev/hda

The number of cylinders for this disk is set to 1058.
There is nothing wrong with that, but this is larger than
1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/hda: 240 heads, 63 sectors, 1058 cylinders
Units = cylinders of 15120 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1         2     15088+  12  Compaq
diagnostics
/dev/hda2             3        36    257040   83  Linux
/dev/hda3   *        37       578   4097520    7  HPFS/NTFS
/dev/hda4           579      1058   3628800    f  Win95
Ext'd (LBA)
/dev/hda5           579       787   1580008+   6  FAT16
/dev/hda6           788       801    105808+  82  Linux swap
/dev/hda7           802       856    415768+  83  Linux
/dev/hda8           857      1058   1527088+  83  Linux


The contents of fstab is as follows:
/dev/hda2 /      ext2    defaults        1 1
/dev/hda7 /home  ext2    defaults        1 2
/dev/hda8 /usr   ext2    defaults        1 2
/dev/hda6        swap    swap    defaults        0 0
/dev/fd0  /mnt/floppy    ext2    noauto          0 0
/dev/cdrom /mnt/cdrom    iso9660 noauto,ro       0 0
none       /proc         proc    defaults        0 0
none     /dev/pts        devpts  gid=5,mode=620       0 0

I added
/dev/hda3        /mnt/ntfs ntfs noauto 0 0

If you need more info please ask.
I would like to upgrade this system without a reinstall.

Stijn Jonker.
Comment 1 ohlen 1999-10-20 00:40:59 EDT
Same thing happened to me, on a Dell Dimension V350, upgrading from
RH5.2 to 6.1 with a slightly different hard disk configuration:

VFS: Error mounting ext2 filesystem on hda1: Invalid argument

Traceback from text install:

Traceback (innermost last)
File "/usr/bin/anaconda", line 225, in ?
   intf.run(todo, test=test)
File
"../../../RedHat/instimage/usr/lib/python1.5/sitepackages/text.py",
line 1000 in run
   rc = apply( step[1](), step[2] )
File
"../../../RedHat/instimage/usr/lib/python1.5/sitepackages/text.py",
lin __call__
   parts = todo.upgradeFindRoot()
File
"../../../RedHat/instimage/usr/lib/python1.5/sitepackages/todo.py",
line 1130, in upgradeFindRoot()
   isys.umount('/mnt/sysimage')
File
"../../../RedHat/instimage/usr/lib/python1.5/sitepackages/isys.py",
line 8 in umount
   return _isys.umount(what)
SystemError: (22,'Invalid argument')

Fdisk output:
------------------------
Command (m for help): p

Disk /dev/hda: 255 heads, 63 sectors, 1024 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start      End   Blocks   Id  System
/dev/hda1   *         1      261  2096451    7  OS/2 HPFS
/dev/hda2           262     1024  6128797+   5  Extended
/dev/hda5           262      597  2698888+  83  Linux native
/dev/hda6           598      750  1228941   83  Linux native
/dev/hda7           751      763   104391   82  Linux swap
/dev/hda8           764      894  1052226    7  OS/2 HPFS
/dev/hda9           895     1024  1044193+   6  DOS 16-bit >=32M
---------------------------------------------------

fstab:
-------
/dev/hda5       /               ext2     defaults        1 1
/dev/hda6       /home           ext2     exec,dev,suid,rw,usrquota 1 2
/dev/hda7       swap            swap     defaults        0 0
/dev/fd0        /mnt/floppy     vfat
user,noexec,nodev,nosuid,rw,noauto 0 0
/dev/hdc        /mnt/cdrom      iso9660
user,exec,dev,nosuid,ro,noauto 0 0
none            /proc           proc     defaults        0 0
/dev/hda9       /WinUsers       vfat
exec,dev,suid,rw,uid=0,gid=10,umask=007
 1 1
apex.ece.ucsb.edu:eci   /eci    nfs      exec,nodev,nosuid,ro 1 1
apex.ece.ucsb.edu:/usr.apex /usr.apex  nfs      exec,nodev,nosuid,ro 1
1
/dev/fd0        /mnt/ext2-floppy        ext2
user,noexec,nodev,nosuid,rw,noa
uto 1 1
Comment 2 Jay Turner 1999-10-21 12:10:59 EDT
This is a duplicate of bug #5555 and therefore I am closing this bug
to prevent further clutter in the system.  Please refer to bug #5555
for further details about the fix to this bug.

Note You need to log in before you can comment on or make changes to this bug.