Bug 578129 - Install fails with greater than 3072 Mb of guest RAM
Install fails with greater than 3072 Mb of guest RAM
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Rik van Riel
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-03-30 06:21 EDT by bobbysch
Modified: 2011-08-08 10:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 10:42:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bobbysch 2010-03-30 06:21:17 EDT
Description of problem: Impossible to install guest with virt-install on a guest with more than 3072 RAM.


Version-Release number of selected component (if applicable): python-virtinst-0.400.3-7.el5


How reproducible: Everytime.
virt-install --os-type=linux --os-variant=virtio26 --accelerate --location=ftp://... --disk path=/dev/mapper/... --name=mac3 --ram=3073 --bridge=br_prod --vnc -x "ks=ftp://.../kickstart.cfg ip=... netmask=... gateway=..." 

--os-variant=rhel5 does not change anything

Steps to Reproduce:
1. The hypervisor (HP ProLiant BL460c G1) has 8Gb of RAM + 8 Gb of swap, and no virtual machine installed.
2. The threshold of RAM attributed to the guest in order to have the error is 3072
3.
  
Actual results:
checking if image is initramfs... it isn't (invalid compressed format (err=1)); looks like an initrd
Freeing initrd memory: 7226k freed

or with --ram=4096 :
checking if image is initramfs... it isn't (bad gzip magic numbers); looks like an initrd
Freeing initrd memory: 7226k freed
...
EXT2-fs: unable to read superblock
isofs_fill_super: bread failed, dev=md1, iso_blknum=16, block=32
No filesystem could mount root, tried: ext2 iso9660
Kernel panic – not syncing: VFS: Unable to mount root fs on unknown-block(9,1)



Expected results: 
With --ram=3072 or less, the installation is working perfectly.



Additional info:
The same problem is seen on the other identical server. But when the RAM of the server is 16 Gb on another server, the problem is not seen.
Comment 1 Cole Robinson 2010-04-06 18:31:58 EDT
Interesting, but this probably a KVM or kernel issue. Reassigning to KVM.
Comment 6 RHEL Product and Program Management 2011-01-11 15:10:14 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 17:50:30 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 8 john cooper 2011-01-17 12:02:27 EST
The problem complaint here is a very common use case (>3GB RWM)
and this problem has not been found elsewhere.  To further
investigate this issue we need far more detail of the test
conditions where this was observed.  It would also be helpful
for the reporter to setup this failure scenario on a remote
machine for a developer to examine.
Comment 12 Rik van Riel 2011-02-18 14:35:31 EST
Bobby, we have never been able to reproduce this bug internally.  However, Prarit did recently find a TLB flushing bug on x86 that could explain your issue.

I have made test kernels with that patch available on http://people.redhat.com/riel/.bz578129/

This is a bit of a long shot, since we have not reproduced the bug internally, but the bug matches your symptoms. Please let us know whether the test kernel resolves your issue, or whether we should keep looking.
Comment 13 juzhang 2011-04-27 00:33:01 EDT
Tried to reproduce this issue using kvm directly with kvm-83-231.el5,failed to reproduce.
I tired to install guest with -m 4G and -m 6G,my host memory is 8G.both can install successful. 

I will try to install system using virt-install later,update soon
Comment 14 juzhang 2011-04-27 01:04:38 EDT
Tried using virt-install,failed to reproduce.

#virt-install --os-type=linux --os-variant=virtio26 --accelerate -l ftp://download.englab.nay.redhat.com/pub/rhel/rel-eng/latest-RHEL-6/6.1/Server/x86_64/os/ --disk path=/var/lib/libvirt/images/foo.img,size=6 --name=foo --ram=4096 --bridge=switch --vnc -x "ks=http://home.englab.nay.redhat.com/~nzhang/kickstart/ftp/ks-rhel6u1-x86_64.cfg" --debug
Wed, 27 Apr 2011 13:03:11 DEBUG    Requesting libvirt URI default
Wed, 27 Apr 2011 13:03:11 DEBUG    Received libvirt URI 'qemu:///system'
Wed, 27 Apr 2011 13:03:11 DEBUG    Requesting virt method 'default'
Wed, 27 Apr 2011 13:03:11 DEBUG    Received virt method 'hvm'
Wed, 27 Apr 2011 13:03:11 DEBUG    Hypervisor name is 'kvm'
Wed, 27 Apr 2011 13:03:11 DEBUG    parse_disk: returning ('/var/lib/libvirt/images/foo.img', None, None, 'disk', None, False, False, 6.0, True, None)
Wed, 27 Apr 2011 13:03:11 DEBUG    Detected storage as type 'file'
Wed, 27 Apr 2011 13:03:11 DEBUG    DistroInstaller location is a network source.


Starting install...
Wed, 27 Apr 2011 13:03:23 DEBUG    Attempting to detect distro:
Wed, 27 Apr 2011 13:03:23 DEBUG    Fetching URI: ftp://download.englab.nay.redhat.com/pub/rhel/rel-eng/latest-RHEL-6/6.1/Server/x86_64/os/.treeinfo
Wed, 27 Apr 2011 13:03:23 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-.treeinfo.8yxXzr
Retrieving file .treeinfo...                                                                                                          | 1.7 kB     00:00     
Wed, 27 Apr 2011 13:03:23 DEBUG    Fetching URI: ftp://download.englab.nay.redhat.com/pub/rhel/rel-eng/latest-RHEL-6/6.1/Server/x86_64/os/images/pxeboot/vmlinuz
Wed, 27 Apr 2011 13:03:23 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-vmlinuz.oFz2zv===========================- ]  0.0 B/s | 3.6 MB     --:-- ETA 
Retrieving file vmlinuz...                                                                      
...........................................

#virt-viewer foo
Comment 15 juzhang 2011-04-27 01:14:45 EDT
Hi,bobbysch

   I tried reproduce this issue using qemu-kvm directly and virt-install tool.all failed.
   Did you still can reproduce this issue on rhel5.7? would you please have a try comment12 patch? thanks.

additional infos:
Host kernel version:
#uname -r
2.6.18-256.el5
Comment 16 Ronen Hod 2011-08-08 10:42:52 EDT
Several people tried to reproduce it, and failed. It was reported once, a long time ago, probably with RHEL5.4. This is typical for bugs that we close for 5.8.

Note You need to log in before you can comment on or make changes to this bug.