Bug 578196 - plymouth:debug halts the boot in KVM
plymouth:debug halts the boot in KVM
Status: CLOSED DUPLICATE of bug 578633
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-30 10:34 EDT by Kamil Páral
Modified: 2010-04-05 11:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-05 11:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from serial console (17.93 KB, application/octet-stream)
2010-03-30 10:34 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2010-03-30 10:34:25 EDT
Created attachment 403508 [details]
log from serial console

Description of problem:
I have used plymouth:debug kernel line on real hardware without problems. But when I try to use it in KVM (virt-manager, libvirt), it just halts the boot, waiting indefinitely. The CPU is not in a loop. I can hit Ctrl+Alt+Delete and it restarts cleanly. But that's all I can do.

The few last lines from serial console:

dracut: Starting plymouth daemon
[main.c]                                 check_logging:checking if console messages should be redirected and logged
[main.c]                                 check_logging:logging will be enabled!
[main.c]                            check_for_consoles:checking if splash screen should be disabled
[main.c]                            check_for_consoles:serial console found!
[main.c]                redirect_standard_io_to_device:redirecting stdio to ttyS0
[main.c]                        initialize_environment:initialized minimal work environment
[main.c]                     attach_to_running_session:creating new terminal session
[ply-terminal-session.c]                   ply_terminal_session_attach:ptmx not passed in, creating one
[ply-terminal-session.c]                           open_pseudoterminal:opening device '/dev/ptmx'
[ply-terminal-session.c]                           open_pseudoterminal: opened device '/dev/ptmx'
[ply-terminal-session.c]                           open_pseudoterminal:creating pseudoterminal
[ply-terminal-session.c]                           open_pseudoterminal:done creating pseudoterminal
[ply-terminal-session.c]                           open_pseudoterminal:unlocking pseudoterminal
[ply-terminal-session.c]                           open_pseudoterminal:unlocked pseudoterminal
[ply-terminal-session.c]                   ply_terminal_session_attach:redirecting system console to terminal device
[ply-terminal-session.c]                   ply_terminal_session_attach:done redirecting system console to terminal device
[main.c]                                          main:entering event loop
[ply-boot-server.c]                ply_boot_connection_on_request:got show splash request
dracut: [ply-event-loop.c] ply_event_loop_stop_watching_fd:stopping watching fd 6d be running
dracut: [ply-event-loop.c] ply_event_loop_stop_watching_fd:removing destination for fd 6

[main.c]                            check_for_consoles:checking if splash screen should be disabled
[main.c]                            check_for_consoles:serial console found!
[main.c]         add_display_and_keyboard_for_terminal:adding display and keyboard for ttyS0
[main.c]                                  set_keyboard:listening for keystrokes
[main.c]                                  set_keyboard:listening for backspace
[main.c]                                  set_keyboard:listening for enter
plymouthd: ply-event-loop.c:707: ply_event_loop_watch_fd: Assertion `fd >= 0' failed.
async/1 used greatest stack depth: 3944 bytes left



Version-Release number of selected component (if applicable):
Fedora 13 Beta RC1 (updated)
dracut-004-5.fc13.noarch
kernel-2.6.33-0.52.rc8.git6.fc13.x86_64
kernel-2.6.33.1-19.fc13.x86_64
kernel-2.6.33-1.fc13.x86_64
plymouth-0.8.1-1.fc13.x86_64
plymouth-core-libs-0.8.1-1.fc13.x86_64
plymouth-gdm-hooks-0.8.1-1.fc13.x86_64
plymouth-graphics-libs-0.8.1-1.fc13.x86_64
plymouth-plugin-label-0.8.1-1.fc13.x86_64
plymouth-plugin-two-step-0.8.1-1.fc13.x86_64
plymouth-scripts-0.8.1-1.fc13.x86_64
plymouth-system-theme-0.8.1-1.fc13.x86_64
plymouth-theme-charge-0.8.1-1.fc13.x86_64
plymouth-utils-0.8.1-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install F13 in KVM.
2. Boot with plymouth:debug.

Additional info:
Full log from serial console attached.
Comment 1 Ray Strode [halfline] 2010-04-05 11:22:40 EDT
Oh this is just the other bug.

*** This bug has been marked as a duplicate of bug 578633 ***

Note You need to log in before you can comment on or make changes to this bug.