Bug 57820 - no color in 'ls' output for NIS users under X
no color in 'ls' output for NIS users under X
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
none
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-24 19:32 EST by Alexei Podtelezhnikov
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 03:30:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2001-12-24 19:32:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20011105

Description of problem:
There is no color in ls output in the following conditions: (a) the user is
not local but rather served by NIS, (b) ls is invoked in any graphical
terminal window under X with any type of shell.

"ls --color" forces fine output. It's only "ls" defaults are messed up or
missing for NIS-served users. Without X it works fine too.

This is just to repeat the forgotten bug 54309.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try "ls" for NIS user under in Xterm, for example. No color.
2. try "ls --color" for the same user. Yes color.
3. switch to text mode. try "ls" and "ls --color". Both color. 
4. for local users there is no difference. Always color.

	

Actual Results:  The ls output for a networked user under X is not in color. 

Expected Results:  ls for network and local users should be the same. Local
users get their output in color.

Additional info: I believe that the problem first showed up after bash
upgrade to 2.05 from rawhide last summer. tcsh etc, however, have the same
problem.
Comment 1 Bernhard Rosenkraenzer 2002-01-10 13:04:16 EST

*** This bug has been marked as a duplicate of 54309 ***
Comment 2 Alexei Podtelezhnikov 2002-01-25 03:30:17 EST
NIS users in our heterogeneous environment had defaults to /bin/tcsh, as it's 
more common in other unixes. 

Here is what happenes for users with tcsh.
Scenario 1. Logging in in virtual console envokes /etc/csh.login and they see 
ls colors.

Scenario 2. Firing up a terminal window under X misses /etc/csh.login and 
envokes only /etc/csh.cshrc. No calls to /etc/profile.d/*.csh are made 
resulting in non-color ls.

Using bash as default invokes /etc/bashrc with or without X and users see 
colors.

Note You need to log in before you can comment on or make changes to this bug.