Bug 578205 - kickstarting on ppc fails due '/usr/sbin/merge-rd.sh' wrong parameters
kickstarting on ppc fails due '/usr/sbin/merge-rd.sh' wrong parameters
Status: CLOSED DUPLICATE of bug 578650
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Jiri Kastner
:
Depends On:
Blocks: 462714 581474
  Show dependency treegraph
 
Reported: 2010-03-30 10:57 EDT by Jiri Kastner
Modified: 2010-07-12 23:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 23:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rhn_check output (8.81 KB, text/plain)
2010-03-30 16:30 EDT, Jiri Kastner
no flags Details

  None (edit)
Description Jiri Kastner 2010-03-30 10:57:21 EDT
Description of problem:
i'm not able to kickstart rhel5.5 for ppc from satellite

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install satellite 5.3.0, update from rhn prod
2. reregister and reactivate system against rhn.webqa
3. sync rhel-ppc-server-5 and its rhn-tools from webqa
4. create rhel5-u5 kickstart profile for ppc
5. register ppc machine and enable provisioning
6. start provisioning of ppc machine
7. on ppc run 'rhn_check -vv'
  
Actual results:
kickstarting fails

Expected results:
kickstarting will start

Additional info:
failed event - https://dell-pe700-01.rhts.eng.bos.redhat.com/network/systems/details/history/event.pxt?sid=1000010044&hid=211
Comment 3 Justin Sherrill 2010-03-30 15:35:40 EDT
Hey Jiri,

Within the event I see "Error creating the new RAM disk".  Where did you see the "/usr/sbin/merge-rd.sh' error?

Thanks!

-Justin
Comment 4 Jiri Kastner 2010-03-30 16:29:49 EDT
on 'rhn_check -vv' output
Comment 5 Jiri Kastner 2010-03-30 16:30:56 EDT
Created attachment 403589 [details]
rhn_check output
Comment 6 Justin Sherrill 2010-03-31 18:51:05 EDT
Ok, Finally i've figured this out.  The problem is that for ppc and s390x we use a different initrd image than /boot/initrd.img.  For ppc we use ramdisk.image.gz.

However spacewalk-koan does not realize this and always tries to use /boot/initrd.img.

Basically file preservation is broken for ppc and s390(x) and has been broken since Satellite 5.3 shipped.  

I will open up a bug for this.  

If i turn off file preservation on the kickstart you are using it gets past the rhn_check and reboots the machine.  However for me it seemed to hang after this and I couldn't seem to get it back into a sane state.  If i tried to reprovision to RHEL 5u4 or u5 using rhts it would traceback at anaconda.
Comment 7 Justin Sherrill 2010-03-31 19:00:36 EDT
Opened bug:

https://bugzilla.redhat.com/show_bug.cgi?id=578650
Comment 9 Clifford Perry 2010-07-12 23:17:18 EDT

*** This bug has been marked as a duplicate of bug 578650 ***

Note You need to log in before you can comment on or make changes to this bug.