Bug 57826 - nautilus didn't start
nautilus didn't start
Status: CLOSED DUPLICATE of bug 57672
Product: Red Hat Raw Hide
Classification: Retired
Component: nautilus (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-12-26 11:37 EST by Joachim Kunze
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-13 11:23:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Kunze 2001-12-26 11:37:56 EST
Description of Problem:

nautilus couldn't be launched

Version-Release number of selected component (if applicable):

Actual Results:
nautilus: relocation error: /usr/lib/libfam.so.0: undefined symbol:
Comment 1 Havoc Pennington 2001-12-28 10:21:46 EST
This has to be some weird toolchain bug rather than a Nautilus/fam issue.
Comment 2 Todd Mokros 2001-12-29 21:17:00 EST
I made a comment on a recent fam bug, but I'll duplicate my comment here:

I'm having the same problem.  I have nautilus-1.0.6-2 and fam-2.6.6-2 installed.
 When I try to start nautilus it gives the following error:
nautilus: relocation error: /usr/lib/libfam.so.0: undefined symbol:

It appears that this symbol should be found in libstdc++.so.4. `ldd
/usr/lib/libfam.so.0` shows:
	libc.so.6 => /lib/i686/libc.so.6 (0x4002c000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

no reference to libstdc++ there, and since nautilus is C not C++, libstdc++
doesn't get linked in.  /usr/bin/fam doesn't have this problem since it's c++.

My guess is either the c++ code in libfam shouldn't be there, or libfam.so.0
needs to be linked with libstdc++.
Comment 3 Todd Mokros 2001-12-29 21:26:57 EST
the following command allows nautilus to start:
LD_PRELOAD=/usr/lib/libstdc++.so.4 nautilus
so it looks like fam needs to be linked against libstdc++.  However, nautilus
can't load any of the sidebars this way, but I don't know if this is because of
the LD_PRELOAD or some other issue.  I'll wait for a good version of fam.  If I
get around to it, I might look at fixing fam myself.  As a side note, I did a
local compile of the plain fam-2.6.7 source and it had the same problem.
Comment 4 Todd Mokros 2001-12-29 21:45:11 EST
This looks like a libtool problem, the link part of the build of libfam is here:
/bin/sh ../libtool --mode=link g++  -g -O2   -o libfam.la -rpath /usr/lib
-export-symbols fam.sym Client.lo fam.lo  

rm -fr .libs/libfam.la .libs/libfam.* .libs/libfam.*

gcc -shared  Client.lo fam.lo   -Wl,-soname -Wl,libfam.so.0
-Wl,-retain-symbols-file -Wl,fam.sym -o .libs/libfam.so.0.0.0

so, for some reason libtool is changing g++ to gcc.
Comment 5 Havoc Pennington 2002-01-13 11:23:51 EST
I think alex was working on this issue
Comment 6 Alexander Larsson 2002-01-13 14:17:53 EST

*** This bug has been marked as a duplicate of 57672 ***

Note You need to log in before you can comment on or make changes to this bug.