Bug 578407 - the prefix '-' in sub-command isn't handled by guestfish in remote control mode
the prefix '-' in sub-command isn't handled by guestfish in remote control mode
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks: 578409
  Show dependency treegraph
 
Reported: 2010-03-31 04:50 EDT by Qixiang Wan
Modified: 2010-05-20 20:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 578409 (view as bug list)
Environment:
Last Closed: 2010-05-12 08:22:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qixiang Wan 2010-03-31 04:50:52 EDT
Description of problem:
In remote control mode of guestfish, the server will normally exit if there is an error in a command. guestfish man page said if we prefix a command with a - character, then that command will not cause guestfish to exit,
but this doesn't work in remote control mode, seems the prefixal '-' in sub-command won't be handled by guestfish.

Version-Release number of selected component (if applicable):
guestfish-1.0.85-1.fc12.3

How reproducible:
100%

Steps to Reproduce:

1. $ eval `guestfish --listen`
2. $ guestfish --remote version
major: 1
minor: 0
release: 85
extra: 
3. $ guestfish --remote -- -lvs
-lvs: unknown command
4. $ guestfish --remote version
guestfish: remote: looks like the server is not running
  
Actual results:
'-' prefixed sub-commands is not recognized by guestfish, and this will cause the guestfish server exit in remote control mode.

Expected results:
sub-commands which prefixed with '-' character should be recognized by guestfish, and this should make guestfish ignore the errors of commands even in remote control mode.

Additional info:
Comment 2 Richard W.M. Jones 2010-04-13 17:28:53 EDT
This should be in the upstream (Virtualization Tools) product.
Comment 3 Fedora Update System 2010-04-20 15:12:22 EDT
libguestfs-1.2.3-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.3-1.el5
Comment 4 Fedora Update System 2010-04-20 18:25:53 EDT
libguestfs-1.2.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.3-1.fc13
Comment 5 Fedora Update System 2010-04-21 08:42:41 EDT
libguestfs-1.2.3-1.fc12.6 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.2.3-1.fc12.6
Comment 6 Fedora Update System 2010-05-20 20:31:33 EDT
libguestfs-1.2.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.