Bug 57855 - New kdebase packages depend on libDCOP.so.1 (no longer exists in kdelibs)
New kdebase packages depend on libDCOP.so.1 (no longer exists in kdelibs)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-28 09:09 EST by Bill Crawford
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-28 09:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2001-12-28 09:09:02 EST
Description of Problem:
kdebase-3.0.0-0.cvs20011227.1 has been built apparently on a system that
still has old libs on it.  A dependency on libDCOP.so.1 has been included
in the RPM dependencies.  This isn't really valid.

I saw a similar problem rebuilding some of the kde packages myself a while
ago, and the problem seems to be that whilst the KDE stuff is technically
"self hosting" it is difficult if not impossible to build them on a system
with an older version still installed and get the dependencies to come out
right.

Upgrading the build system to the new version with --nodeps and then
redoing the build seems to be the only fix I could find; I cannot yet
verify that will work for this package (I'm about to try it though).
Comment 1 Bernhard Rosenkraenzer 2002-01-08 13:56:50 EST
You can prevent the build from picking up previously existing libraries by removing a couple of bogus rpath statements from the admin scripts.
Done in 3.0.0-0.cvs20020107.1

Note You need to log in before you can comment on or make changes to this bug.