Bug 57858 - su fails to truncate long passwords
Summary: su fails to truncate long passwords
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-28 18:48 UTC by kenneth_porter
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-09 20:01:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kenneth_porter 2001-12-28 18:48:05 UTC
Prior to upgrading to RH 7.2, my root password was longer than 8 
characters, and entering the whole thing was accepted by su. Following the 
upgrade (sh-utils-2.0.11-5), I can enter the long password with the passwd 
command, but I must only enter the first 8 characters to su. su rejects 
the longer password.

I believe there's a similar problem with the main desktop login, so this 
may be a PAM issue.

Comment 1 Bernhard Rosenkraenzer 2002-01-09 15:16:49 UTC
Works for me...
Are you sure MD5 passwords are enabled? (MD5 passwords are on if the password hashes in /etc/shadow start with "$1$")


Comment 2 kenneth_porter 2002-01-09 20:01:35 UTC
MD5 is not specified in /etc/pam.d/system-auth, and there are no "$1$" style
prefixes in /etc/shadow.

Comment 3 Bernhard Rosenkraenzer 2002-01-22 22:46:39 UTC
long passwords don't work unless md5 passwords are enabled. Please use
"authconfig" to fix your configuration.


Note You need to log in before you can comment on or make changes to this bug.