Bug 578588 - DeviceError: ('cannot replace active format', 'sda')
Summary: DeviceError: ('cannot replace active format', 'sda')
Keywords:
Status: CLOSED DUPLICATE of bug 563526
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:f156cd713fd3c77c7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-31 18:07 UTC by Mark Gordon
Modified: 2013-07-28 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-12 22:42:18 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (92.26 KB, text/plain)
2010-03-31 18:08 UTC, Mark Gordon
no flags Details
Attached traceback automatically from anaconda. (88.54 KB, text/plain)
2010-04-28 13:17 UTC, Chandrasekar Kannan
no flags Details
Attached traceback automatically from anaconda. (90.84 KB, text/plain)
2010-04-28 13:23 UTC, Chandrasekar Kannan
no flags Details

Description Mark Gordon 2010-03-31 18:07:58 UTC
The following was filed automatically by anaconda:
anaconda 13.21.20.3 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/partitioning.py", line 401, in removeEmptyExtendedPartitions
    destroy_action = ActionDestroyFormat(disk)
  File "/usr/lib/anaconda/storage/partitioning.py", line 373, in clearPartitions
    removeEmptyExtendedPartitions(storage)
  File "/usr/lib/anaconda/kickstart.py", line 301, in execute
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/kickstart.py", line 1086, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1035, in <module>
    ksdata.execute()
DeviceError: ('cannot replace active format', 'sda')

Comment 1 Mark Gordon 2010-03-31 18:08:02 UTC
Created attachment 403802 [details]
Attached traceback automatically from anaconda.

Comment 3 RHEL Product and Program Management 2010-03-31 18:48:04 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 David Lehman 2010-04-12 22:42:18 UTC

*** This bug has been marked as a duplicate of bug 563526 ***

Comment 5 Chandrasekar Kannan 2010-04-28 13:17:30 UTC
Created attachment 409824 [details]
Attached traceback automatically from anaconda.

Comment 6 Chandrasekar Kannan 2010-04-28 13:23:57 UTC
Created attachment 409830 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.